Bug 1262121 - [RFE] Support for encypted volumes backed by RBD via QEMU
[RFE] Support for encypted volumes backed by RBD via QEMU
Status: CLOSED DUPLICATE of bug 1285089
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
high Severity medium
: ga
: 10.0 (Newton)
Assigned To: Eoghan Glynn
nlevinki
: FutureFeature
Depends On: 1301021
Blocks: 1262120
  Show dependency treegraph
 
Reported: 2015-09-10 16:37 EDT by Neil Levine
Modified: 2016-05-09 05:55 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1297980 (view as bug list)
Environment:
Last Closed: 2016-05-09 05:55:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 206576 None None None 2016-01-12 13:33 EST
OpenStack gerrit 239798 None None None 2016-01-12 17:18 EST

  None (edit)
Description Neil Levine 2015-09-10 16:37:04 EDT
Cinder supports an encrypted volume type. This needs to be supported by QEMU against RBD-backed Cinder volumes.
Comment 8 Daniel Berrange 2016-01-13 04:48:04 EST
QEMU patches to support this feature are pending review

https://lists.gnu.org/archive/html/qemu-devel/2015-12/msg04354.html
Comment 12 Lee Yarwood 2016-05-09 05:55:10 EDT
Marking as a duplicate of RHBZ#1285089 where we are looking into moving to using QEMU's native LUKS support in the future.

*** This bug has been marked as a duplicate of bug 1285089 ***

Note You need to log in before you can comment on or make changes to this bug.