Bug 126215 - Disable menu editing menu items (e.g. "Add new item to this menu")
Disable menu editing menu items (e.g. "Add new item to this menu")
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-panel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 12:52 EDT by Marizol Martinez
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-11 11:14:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marizol Martinez 2004-06-17 12:52:15 EDT
Description of problem:

**This is the same bug that has been reported for Fedora Core (bug
#107899)**

Applications cannot be added to Applications menu, unless the .desktop
files are dropped in ~/.gnome2/vfolders/applications.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Open Applications menu, go into any other menu (e.g. Accessories).
2. Right click, choose Entire menu, then Add new item to this menu.
3. Fill in the details of the application.
4. Click OK.

Actual Results:  Application (launcher) cannot be added. Following
error message is presented:
 
            Cannot save menu item to disk

            Details: Error writing file 
            'applications:/Accessories/t.desktop':
            Unsupported operation

Expected Results:  Should be possible to add new applications.

Additional info:
Comment 1 Joshua Jensen 2005-04-20 14:31:04 EDT
Hello?   This is known as a major major bug, right?  As a user you can't change
your own apps menu?!!
Comment 2 Mark McLoughlin 2005-04-27 04:16:27 EDT
Menu editing is not supported in GNOME on RHEL3.

The bug that needs to be fixed here is that the "Add new item to this menu"
should be disabled, since it doesn't do anything.
Comment 3 Mark McLoughlin 2005-07-11 11:14:01 EDT
Okay, closing this bug because we're unlikely to ever release a RHEL3 errata
just to disable these menu items. They're not very visible in the menus and they
just display a warning dialog, so it doesn't seem worth it.

However, menu editing is something that is being worked on upstream in GNOME.

Note You need to log in before you can comment on or make changes to this bug.