Bug 1262231 - [HC] gluster crashed, when the machine (RHEL 7.1) is rebooted
[HC] gluster crashed, when the machine (RHEL 7.1) is rebooted
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
: Triaged
Depends On:
Blocks: 1260007
  Show dependency treegraph
 
Reported: 2015-09-11 04:29 EDT by SATHEESARAN
Modified: 2017-02-11 20:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEL 7.1 ( converged setup with virt and gluster )
Last Closed: 2016-02-26 01:41:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2015-09-11 04:29:49 EDT
Description of problem:
-----------------------
gluster-server is installed in RHEL 7.1
When this server is rebooted, glusterd crashes

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
3.8dev build

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Install glusterfs-server
2. start glusterd
3. Enable glusterd across reboot ( if not already enabled )
4. Reboot the machine

Actual results:
---------------
glusterd crashes

Expected results:
-----------------
glusterd should come up across reboots

Additional info:
----------------
Restarting glusterd doesn't have this problem
Comment 1 SATHEESARAN 2015-09-11 04:30:34 EDT
I couldn't get the coredump as the /var/log/core location is empty

[2015-09-11 07:18:53.668711] E [MSGID: 101066] [graph.c:323:glusterfs_graph_init] 0-management: initializing translator failed
pending frames:
patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 
2015-09-11 07:18:53
configuration details:
argp 1
backtrace 1
dlfcn 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.8dev
[2015-09-11 07:18:53.668723] E [MSGID: 101176] [graph.c:669:glusterfs_graph_activate] 0-graph: init failed
/lib64/libglusterfs.so.0(_gf_msg_backtrace_nomem+0xc2)[0x7f8e43922c72]
/lib64/libglusterfs.so.0(gf_print_trace+0x31d)[0x7f8e4393f12d]
/lib64/libc.so.6(+0x35650)[0x7f8e42011650]
[0x7f8e3856a0ea]
[0x7f8e38490ede]
[0x7f8e38486dac]
/lib64/libgfrpc.so.0(rpc_clnt_notify+0xd0)[0x7f8e436f1be0]
/lib64/libgfrpc.so.0(rpc_transport_notify+0x23)[0x7f8e436ed813]
/usr/lib64/glusterfs/3.8dev/rpc-transport/socket.so(socket_connect_error_cbk+0x2d)[0x7f8e361d38fd]
/lib64/libpthread.so.0(+0x7df5)[0x7f8e4278bdf5]
/lib64/libc.so.6(clone+0x6d)[0x7f8e420d21ad]
---------
Comment 3 Atin Mukherjee 2015-09-16 00:11:32 EDT
The difficulty of analysing the issue is that the core file is not generated, from the log it looks like GlusterD's fini () has caused the crash. Also as per QE this *only* happens in a hyper convergence set up. Further analysis needs to go on.
Comment 4 SATHEESARAN 2015-09-28 02:36:51 EDT
I am not seeing this issue on when rebooting the VMs installed with glusterfs 3.8dev builds. 

I will re-check the issue and close this bug if not reproducible
Comment 6 Byreddy 2015-12-07 23:12:36 EST
The Comment 5 info is added mistakenly here (Invalid info to this bug)
Comment 7 Sahina Bose 2016-02-12 01:39:14 EST
Sas, is this bug still applicable? I have not seen this on RHEL 7.2 with glusterfs 3.7.5-18.32
Comment 8 Atin Mukherjee 2016-02-26 01:41:09 EST
Sas,

I am closing this bug, if you happen to hit it feel free to reopen.

~Atin
Comment 9 SATHEESARAN 2017-02-11 20:38:11 EST
(In reply to Sahina Bose from comment #7)
> Sas, is this bug still applicable? I have not seen this on RHEL 7.2 with
> glusterfs 3.7.5-18.32

No this issue is not hit with the latest 3.8 bits and RHEL 7.3. You can safely ignore this bug

Note You need to log in before you can comment on or make changes to this bug.