Bug 1262246 - Augeas based config parser requires spaces around '='
Augeas based config parser requires spaces around '='
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreport (Show other bugs)
6.7
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Jakub Filak
Martin Kyral
: EasyFix, Patch
Depends On:
Blocks: 1254457
  Show dependency treegraph
 
Reported: 2015-09-11 05:16 EDT by Siteshwar Vashisht
Modified: 2016-05-10 20:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: libreport-2.0.9-28.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:39:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (2.26 KB, patch)
2015-11-19 09:30 EST, Jakub Filak
no flags Details | Diff

  None (edit)
Description Siteshwar Vashisht 2015-09-11 05:16:05 EDT
Description of problem:
Augeas based config parser requires spaces around '='

Version-Release number of selected component (if applicable):
libreport-2.0.9-24.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a user acccount with id 'test' and add below lines in '/etc/libreport/plugins/mailx.conf' :

Subject="abrt crash report"
EmailFrom="root"
EmailTo="test@localhost"

2. Execute 'sleep 60 &' in terminal
3. Kill sleep process by executing 'kill -11 $(pidof sleep)'.

Actual results:
mailx plugin sends an email to 'root@localhost' address.

Expected results:
mailx plugin should send an email to 'test@localhost' address.

Additional info:
mailx plugin behaves properly if spaces are added around '='.

This bug is not reproducible on RHEL 6.6.

Change of behaviour was introduced by https://github.com/abrt/libreport/commit/b82232e57e4b1f61168652e8700bdf800a8525cf and it should be fixed by backporting https://github.com/abrt/libreport/commit/426953f8dd165339fc3ca9a8975fe2fe9efc8162
Comment 2 Jakub Filak 2015-11-19 09:32:17 EST
I pushed the patch to rhel-6.8-staging branch.
Comment 6 errata-xmlrpc 2016-05-10 20:39:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0920.html

Note You need to log in before you can comment on or make changes to this bug.