Bug 1262298 - Document recommendation for configuring non-exclusive LVM resource to monitor volume in an active/active cluster
Document recommendation for configuring non-exclusive LVM resource to monitor...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Global_File_System_2 (Show other bugs)
6.8
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation
Depends On:
Blocks: 1327256
  Show dependency treegraph
 
Reported: 2015-09-11 07:16 EDT by Steven J. Levine
Modified: 2017-03-22 11:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1327256 (view as bug list)
Environment:
Last Closed: 2017-03-22 11:27:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2015-09-11 07:16:57 EDT
For RHEL 7, we added a procedure to the GFS2 manual on configuring GFS2 with Pacemaker. Since Pacemaker is supported in RHEL 6, we should add this procedure to the RHEL 6 document as well. There are, however, some differences -- specifically the fact that clvmd be started directly using the init service (service clvmd start/stop/status, or chkconfig clvmd on).

There is a Portal article on this topic:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Global_File_System_2/ch-clustsetup-GFS2.html

This should be made clear (quoring Frank Danapfel):

-------
> The resource created in https://access.redhat.com/solutions/530223 is a volume group, not one for managing clvmd.

IMHO, this is not apparently clear when reading the kbase, since the
text of the kbase the whole time talks about clvmd, and even mentions at
the end that it would be possible to use clvmd as a resource:

"NOTE: If the clvmd service is managed by a Pacemaker resource, as
opposed to being started on boot by the init service, the resource
monitor interval should not be set too low."

Therefore it would be great if the kbase article could be improved to
make it clear that clvmd must be started by init on RHEL6 even with
pacemaker.
-----------------
Comment 9 Steven J. Levine 2017-03-22 11:27:04 EDT
Since this is now on the Portal I'm closing this BZ:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Global_File_System_2/ch-clustsetup-GFS2.html

Note You need to log in before you can comment on or make changes to this bug.