Bug 126232 - cannot turn off IPv6
Summary: cannot turn off IPv6
Status: CLOSED DUPLICATE of bug 125587
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-17 19:55 UTC by Florin Andrei
Modified: 2014-03-17 02:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florin Andrei 2004-06-17 19:55:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
At the end of /etc/sysconfig/network i added this line:

NETWORKING_IPV6=no

Then did a reboot.
However, that did not turn off IPv6: the ipv6 module still loaded up,
the interfaces were still having IPv6 addresses.

Then i added this line to /etc/modprobe.conf:

install ipv6 /bin/true

That turned off IPv6.

It looks like the NETWORKING_IPV6 is not honored by the start-up scripts.

Version-Release number of selected component (if applicable):
initscripts-7.53-1

How reproducible:
Always

Steps to Reproduce:
1.doh, see above
2.
3.
    

Actual Results:  doh, see above

Expected Results:  doh, see above

Additional info:

This is a FC2 system on an AthlonXP, kept up-to-date with yum.

Comment 1 Bill Nottingham 2004-06-29 04:49:22 UTC

*** This bug has been marked as a duplicate of 125587 ***

Comment 2 Kenneth Porter 2004-07-12 20:47:39 UTC
For me, lsmod currently shows 28 clients for the ipv6 module on one
system, 18 on another, but no indication of what they are. (The first
system has more interfaces.) How might one determine that? That should
help in figuring out what's pulling it into memory.

Comment 3 Red Hat Bugzilla 2006-02-21 19:04:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.