Bug 1262322 - Failed to backup CS.cfg message in upgrade.
Failed to backup CS.cfg message in upgrade.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 08:19 EDT by Martin Bašti
Modified: 2015-11-19 07:06 EST (History)
5 users (show)

See Also:
Fixed In Version: ipa-4.2.0-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:06:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bašti 2015-09-11 08:19:44 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/5287

On ipa upgrade there is always a message:
{{{
Failed to backup CS.cfg: Dogtag must be stopped when creating backup of /var/lib/pki/pki-tomcat/conf/ca/CS.cfg.
}}}

I don't know if a backup of the file was or was not successful. Either way something is not working.
Comment 4 Scott Poore 2015-10-02 14:41:46 EDT
How can I verify this?  I see CS.cfg backed up during ipa-server-install on RHEL7.1 in the ipaserver-install.log.  But, after upgrade, I don't see any mention of backing up the CS.cfg file in the ipaupgrade.log file.

It does look from timestamps though as if it was backed up:

[root@rhel7-9 ca]# ls -l /var/log/ipaupgrade.log 
-rw-------. 1 root root 5338433 Oct  2 13:22 /var/log/ipaupgrade.log

[root@rhel7-9 ca]# ls -l /var/lib/pki/pki-tomcat/conf/ca/CS*
-rw-rw----. 1 pkiuser pkiuser 82227 Oct  2 13:22 /var/lib/pki/pki-tomcat/conf/ca/CS.cfg
lrwxrwxrwx. 1 pkiuser pkiuser    66 Oct  2 13:21 /var/lib/pki/pki-tomcat/conf/ca/CS.cfg.bak -> /var/lib/pki/pki-tomcat/conf/ca/archives/CS.cfg.bak.20151002132122
-rw-rw----. 1 root    root    82223 Oct  2 13:20 /var/lib/pki/pki-tomcat/conf/ca/CS.cfg.ipabkp

Unless that comes from a pki restart.

How can I confirm this fix?
Comment 5 Scott Poore 2015-10-02 14:45:37 EDT
Or is this what I'm looking for?

[root@rhel7-9 log]# grep "Successfully backed up.*CS.cfg" /var/log/messages 
Oct  2 13:20:37 rhel7-9 pkidaemon: SUCCESS:  Successfully backed up '/var/lib/pki/pki-tomcat/conf/ca/CS.cfg.bak'
Oct  2 13:21:22 rhel7-9 pkidaemon: SUCCESS:  Successfully backed up '/var/lib/pki/pki-tomcat/conf/ca/CS.cfg.bak'
Comment 6 Scott Poore 2015-10-02 16:26:02 EDT
Or is it enough to make sure the error messages is not there?

[root@rhel7-9 log]# grep "Dogtag must be stopped when creating backup of.*CS.cfg" /var/log/messages 
[root@rhel7-9 log]# grep "Dogtag must be stopped when creating backup of.*CS.cfg" /var/log/ipaupgrade.log 
[root@rhel7-9 log]# grep "Dogtag must be stopped when creating backup of.*CS.cfg" /tmp/yum.update.out 
[root@rhel7-9 log]# 


Thanks
Comment 7 Scott Poore 2015-10-02 16:55:57 EDT
Verified.

Version ::

ipa-server-4.2.0-12.el7.x86_64

Results ::

[root@rhel7-9 log]# grep "Dogtag must be stopped when creating backup of.*CS.cfg" /var/log/messages 

[root@rhel7-9 log]# grep "Dogtag must be stopped when creating backup of.*CS.cfg" /var/log/ipaupgrade.log 

[root@rhel7-9 log]# grep "Dogtag must be stopped when creating backup of.*CS.cfg" /tmp/yum.update.out 

[root@rhel7-9 log]# ls -l /var/log/ipaupgrade.log 
-rw-------. 1 root root 5338433 Oct  2 13:22 /var/log/ipaupgrade.log

[root@rhel7-9 log]# ls -l /var/lib/pki/pki-tomcat/conf/ca/CS.cfg.ipabkp
-rw-rw----. 1 root root 82223 Oct  2 13:20 /var/lib/pki/pki-tomcat/conf/ca/CS.cfg.ipabkp
[root@rhel7-9 log]#
Comment 8 Martin Bašti 2015-10-05 03:20:50 EDT
Verification steps looks good for me
Comment 9 errata-xmlrpc 2015-11-19 07:06:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.