Bug 1262332 - ff cant save video on arm64
ff cant save video on arm64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox (Show other bugs)
7.2
aarch64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
:
Depends On:
Blocks: 1357680
  Show dependency treegraph
 
Reported: 2015-09-11 08:38 EDT by Tomas Pelka
Modified: 2017-06-28 09:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 09:46:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2015-09-11 08:38:28 EDT
Description of problem:
On aarch64 I'm not able to save a video from browser

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. open browser
2. I used http://video.blendertestbuilds.de/download.blender.org/peach/trailer_1080p.ogg
3. the video starts playing
4. from context me pick Save As..
5. Save the file somewhere

Actual results:
Nothing crash but I can see following message on cmdline. File is not saved.
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: Argument 5 of splice is undefined
Full stack: ffi@resource://gre/modules/osfile/osfile_shared_allthreads.jsm:1109:1
pump_splice@resource://gre/modules/osfile/osfile_unix_front.jsm:603:1
copy@resource://gre/modules/osfile/osfile_unix_front.jsm:659:23
move@resource://gre/modules/osfile/osfile_unix_front.jsm:708:8
move@resource://gre/modules/osfile/osfile_async_worker.js:207:1
worker.dispatch@resource://gre/modules/osfile/osfile_async_worker.js:31:26
anonymous/AbstractWorker.prototype.handleMessage@resource://gre/modules/workers/PromiseWorker.js:122:16
@resource://gre/modules/osfile/osfile_async_worker.js:46:43

*************************


Expected results:
no error video should be saved

Additional info:
Comment 1 Yaakov Selkowitz 2017-06-27 15:50:37 EDT
I am unable to reproduce this with firefox-52.2.0-1.el7_3.aarch64 on an updated RHELSA 7.3 system.  The example URI is no longer valid, but I uploaded a webm video to a private location and tried the same.  Also note that there is no longer a "Save As..." but separate "Save Video As..." and "Save Snapshot As..."; I tried the former, and the video was saved successfully.

Are you still able to reproduce this on an updated RHELSA 7.3 system?
Comment 2 Tomas Pelka 2017-06-28 09:46:39 EDT
Right can't reproduce either with firefox-52.2.0-1.el7_3.aarch64.

And yes they changed the link.

Note You need to log in before you can comment on or make changes to this bug.