Bug 1262438 - Error not propagated correctly if selfheal layout lock fails
Error not propagated correctly if selfheal layout lock fails
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nithya Balachandran
:
Depends On:
Blocks: 1263191
  Show dependency treegraph
 
Reported: 2015-09-11 12:44 EDT by Nithya Balachandran
Modified: 2016-06-16 09:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1263191 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:36:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-09-11 12:44:55 EDT
Description of problem:

The op_errno is not propagated correctly on failure in dht_selfheal_layout_lock_cbk

Log messages:

[2015-09-10 11:30:17.710010] W [MSGID: 114031] [client-rpc-fops.c:2322:client3_3_setattr_cbk] 5-vol-client-2: remote operation failed [Stale file handle]
[2015-09-10 11:30:17.710173] W [fuse-resolve.c:65:fuse_resolve_entry_cbk] 0-fuse: 00000000-0000-0000-0000-000000000001/glusterfs: failed to resolve (Structure needs cleaning) 
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Nithya Balachandran 2015-09-11 13:04:16 EDT
Patch posted at:
http://review.gluster.org/#/c/12165/
Comment 2 Vijay Bellur 2015-09-12 10:17:22 EDT
REVIEW: http://review.gluster.org/12165 (cluster/dht : Propagate op_errno on failure) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2015-09-14 02:29:12 EDT
COMMIT: http://review.gluster.org/12165 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 2ec8ea8769e943d3987dd80f8f6937359bcccf34
Author: Nithya Balachandran <nbalacha@redhat.com>
Date:   Fri Sep 11 22:18:03 2015 +0530

    cluster/dht : Propagate op_errno on failure
    
    Fixed issue where dht_selfheal_layout_lock_cbk does not propagate
    the op_errno.
    
    Change-Id: I0b968339db65d2969e36e64407eeb724cc6516bd
    BUG: 1262438
    Signed-off-by: Nithya Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12165
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:36:54 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.