Bug 1262457 - kbruch does not launch from XDG menu
kbruch does not launch from XDG menu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kbruch (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 14:53 EDT by Yaakov Selkowitz
Modified: 2015-09-24 04:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: 15.08.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-19 14:54:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for rawhide (1.77 KB, patch)
2015-09-11 15:24 EDT, Yaakov Selkowitz
no flags Details | Diff
Patch for f23 (1.89 KB, patch)
2015-09-11 15:34 EDT, Yaakov Selkowitz
no flags Details | Diff

  None (edit)
Description Yaakov Selkowitz 2015-09-11 14:53:52 EDT
kbruch fails to launch from an XDG menu with the following error message to stderr:

Unknown options: c, a, p, t, i, o, n.

This is explained in full here:

https://community.kde.org/Frameworks/Porting_Notes#Application

F22, F23, and rawhide are all affected.
Comment 1 Rex Dieter 2015-09-11 15:08:32 EDT
Indeed, confirmed... looks like the shortcut has been broke ever since it was ported to kf5.
Comment 2 Yaakov Selkowitz 2015-09-11 15:24:18 EDT
Created attachment 1072621 [details]
Patch for rawhide

Successful scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=11052010
Comment 3 Yaakov Selkowitz 2015-09-11 15:34:51 EDT
Created attachment 1072622 [details]
Patch for f23

This can be subsequently merged into f22.  Successful scratch builds:

http://koji.fedoraproject.org/koji/taskinfo?taskID=11052458 (f23)
http://koji.fedoraproject.org/koji/taskinfo?taskID=11052466 (f22)
Comment 4 Fedora Update System 2015-09-11 15:48:15 EDT
kbruch-15.08.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15653
Comment 5 Fedora Update System 2015-09-11 15:50:05 EDT
kbruch-15.08.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15654
Comment 6 Fedora Update System 2015-09-12 17:25:10 EDT
kbruch-15.08.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kbruch'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15653
Comment 7 Fedora Update System 2015-09-13 00:20:12 EDT
kbruch-15.08.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kbruch'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15654
Comment 8 Fedora Update System 2015-09-19 14:54:56 EDT
kbruch-15.08.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-09-24 04:25:07 EDT
kbruch-15.08.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.