Bug 1262471 - decode clflushopt instruction
decode clflushopt instruction
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdb (Show other bugs)
7.2
x86_64 Linux
low Severity low
: rc
: 7.3
Assigned To: Jan Kratochvil
qe-baseos-tools
:
Depends On:
Blocks: 1297579 1313485 1262479 1357895
  Show dependency treegraph
 
Reported: 2015-09-11 16:08 EDT by Jeff Bastian
Modified: 2016-11-03 23:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: gdb-7.6.1-84.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
: 1262479 1357895 (view as bug list)
Environment:
Last Closed: 2016-11-03 23:49:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2015-09-11 16:08:35 EDT
Description of problem:
Please add support to gdb and crash to decode the new CLFLUSHOPT instruction (in Intel Skylake and newer CPUs).  Currently gdb shows the 0x66 prefix as a separate instruction, but objdump decodes it correctly:

$ echo 'int main(void) { asm volatile("clflushopt (%rdi)"); }' > clflushopt.c
$ gcc -g clflushopt.c
$ objdump -d a.out | grep clflush
  4004f4:       66 0f ae 3f             clflushopt (%rdi)
$ gdb -q ./a.out
Reading symbols from /tmp/clflushopt/a.out...done.
(gdb) disas /r main
Dump of assembler code for function main:
...
   0x00000000004004f4 <+4>:     66      data16
   0x00000000004004f5 <+5>:     0f ae 3f        clflush (%rdi)


Version-Release number of selected component (if applicable):
gdb-7.6.1-78.el7
crash-7.1.2-2.el7

How reproducible:
always

Steps to Reproduce:
1. see above

Actual results:
   0x00000000004004f4 <+4>:     66      data16
   0x00000000004004f5 <+5>:     0f ae 3f        clflush (%rdi)

Expected results:
   0x00000000004004f4 <+4>:     66 0f ae 3f     clflushopt (%rdi)

Additional info:
See bug 1170846 comment 19 for where the issue was seen with crash
Comment 5 errata-xmlrpc 2016-11-03 23:49:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2328.html

Note You need to log in before you can comment on or make changes to this bug.