Bug 1262484 - Fedora 21 doesn't contain F23 gpg keys: upgrade with dnf fails
Fedora 21 doesn't contain F23 gpg keys: upgrade with dnf fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
RejectedFreezeException
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 16:48 EDT by Giulio 'juliuxpigface'
Modified: 2015-10-04 19:20 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 19:20:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giulio 'juliuxpigface' 2015-09-11 16:48:32 EDT
Description of problem:
dnf system-upgrade can't upgrade Fedora 21 to Fedora 23. Similarly to bug 1220358 (which refers to bug 1214150), the F23 gpg-keys are missing from F21.

After importing them, the upgrade succeeded.

Version-Release number of selected components:
fedora-release-21.2.noarch
dnf-plugin-system-upgrade-0.4.0-1.fc21.noarch
python2-dnf-plugin-system-upgrade-0.4.0-1.fc21.noarch
dnf-plugins-core-0.1.5-2.fc21.noarch
dnf-0.6.4-6.fc21.noarch

How reproducible:
Haven't tried to reproduce it, but the output message is clear enough.

Steps to Reproduce:
1. Boot Fedora 21
2. Perform a "# dnf update" (in my case, repos updates-testing were enabled)
3. Install dnf-plugin-system-upgrade
4. "# dnf system-upgrade download --releasever=23"

Actual results:
Upgrade fails with this output:

warning: /var/lib/dnf/system-upgrade/kernel-core-4.2.0-300.fc23.x86_64.rpm: Header V3 RSA/SHA256 Signature, ID chiave 34ec9cba: NOKEY

Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-23-X86_64 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-23-x86_64]

Expected results:
The gpg-key should be available and the upgrade should pass.
Comment 1 Fedora Blocker Bugs Application 2015-09-12 04:37:49 EDT
Proposed as a Freeze Exception for 23-beta by Fedora user juliuxpigface using the blocker tracking app because:

 To be honest, it's not entirely clear if upgrading from "Fedora n-1 to Fedora n+1" is (or should be) officially supported. But, since this seems the only known bug that prevents that kind of upgrade, it would be nice to get it fixed, anyway (If not for beta, at least for the final milestone).
Comment 2 Fedora Update System 2015-09-12 12:05:20 EDT
fedora-repos-21-3 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15683
Comment 3 Giulio 'juliuxpigface' 2015-09-12 16:29:34 EDT
Tested the updated package.

I can confirm it solves the issue. Fedora 23 gpg-key is now automatically imported during the process.

Thank you!
Comment 4 Fedora Update System 2015-09-12 23:49:05 EDT
fedora-repos-21-3 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update fedora-repos'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15683
Comment 5 Adam Williamson 2015-09-14 13:02:24 EDT
Discussed at 2015-09-14 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-14/f23-blocker-review.2015-09-14-16.00.log.txt . Rejected as a freeze exception: as the fix for this goes to F21, not F23, it doesn't need an exception for the F23 freeze.

If this constituted a blocker it would be a 'special blocker' (requiring that the update for F21 ship before F23 Beta was shipped), but N-2 upgrades are specifically *not* release blocking, so that doesn't apply.
Comment 6 Fedora Update System 2015-10-04 19:20:43 EDT
fedora-repos-21-3 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.