Bug 1262486 - RHEL 6 RHGS 3.1 image ships with the same glusterd.info
RHEL 6 RHGS 3.1 image ships with the same glusterd.info
Status: CLOSED DUPLICATE of bug 1245536
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: ami (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sreenath G
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-11 17:04 EDT by Jacob Shucart
Modified: 2016-09-20 01:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-13 23:35:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Shucart 2015-09-11 17:04:33 EDT
Description of problem:

Launch 2 instances of the current RHGS 3.1 AMI.  Compare /var/lib/glusterd/glusterd.info.  They are identical.  This causes problems when you go to create a Gluster volume.  This file should probably be scrubbed from the image.
Comment 2 Atin Mukherjee 2015-09-13 23:35:37 EDT
(In reply to Jacob Shucart from comment #0)
> Description of problem:
> 
> Launch 2 instances of the current RHGS 3.1 AMI.  Compare
> /var/lib/glusterd/glusterd.info.  They are identical.  This causes problems
> when you go to create a Gluster volume.  This file should probably be
> scrubbed from the image.

This problem is already addressed by BZ 1245536 and the fix will be available in 3.1.1. Marking it as duplicate and closing it.

*** This bug has been marked as a duplicate of bug 1245536 ***
Comment 3 SATHEESARAN 2015-09-14 01:02:03 EDT
Addition to comment2, glusterd.info will not be generated with fresh install of RHGS 3.1.1

If you have older RHGS 3.1 and upgrade to RHGS 3.1.1, you will still notice the problem. In that case, remove glusterd.info and restart glusterd on that node

Note You need to log in before you can comment on or make changes to this bug.