Bug 1262524 - [abrt] dnf: main.py:94:main:NameError: global name 'self' is not defined
[abrt] dnf: main.py:94:main:NameError: global name 'self' is not defined
Status: CLOSED DUPLICATE of bug 1259194
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f95385d77a19de08e2edf06a1c6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-12 03:27 EDT by Gerhard
Modified: 2015-09-14 08:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 08:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (581 bytes, text/plain)
2015-09-12 03:27 EDT, Gerhard
no flags Details
File: environ (2.46 KB, text/plain)
2015-09-12 03:27 EDT, Gerhard
no flags Details

  None (edit)
Description Gerhard 2015-09-12 03:27:45 EDT
Version-Release number of selected component:
dnf-1.1.1-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python -OO /bin/dnf install steam
dso_list:       python-dnf-1.1.1-1.fc22.noarch
executable:     /bin/dnf
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
main.py:94:main:NameError: global name 'self' is not defined

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 195, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 94, in main
    demands = self.cli.demands
NameError: global name 'self' is not defined

Local variables in innermost frame:
base: <dnf.cli.cli.BaseCli object at 0x7fa9d3152dd0>
e: DepsolveError()
args: ['install', 'steam']
Comment 1 Gerhard 2015-09-12 03:27:49 EDT
Created attachment 1072682 [details]
File: backtrace
Comment 2 Gerhard 2015-09-12 03:27:50 EDT
Created attachment 1072683 [details]
File: environ
Comment 3 Michal Luscon 2015-09-14 08:04:07 EDT

*** This bug has been marked as a duplicate of bug 1259194 ***

Note You need to log in before you can comment on or make changes to this bug.