This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1262525 - [abrt] remmina: memmove(): remmina killed by SIGSEGV
[abrt] remmina: memmove(): remmina killed by SIGSEGV
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: remmina (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4abf3cae236a45597b0e13842af...
:
: 1294603 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-12 03:32 EDT by Gerhard
Modified: 2016-01-05 16:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-05 16:11:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (154.88 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: cgroup (190 bytes, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: core_backtrace (16.77 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: dso_list (13.49 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: environ (1.60 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: maps (69.63 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: mountinfo (4.07 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: open_fds (4.11 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: proc_pid_status (1011 bytes, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details
File: var_log_messages (18.31 KB, text/plain)
2015-09-12 03:32 EDT, Gerhard
no flags Details

  None (edit)
Description Gerhard 2015-09-12 03:32:22 EDT
Description of problem:
I think it happened during copy & paste.

Version-Release number of selected component:
remmina-1.2.0-0.5.git.b3237e8.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        remmina
crash_function: memmove
executable:     /usr/bin/remmina
global_pid:     12448
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 memmove at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:164
 #2 freerdp_image32_copy at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/codec/color.c:3112
 #3 freerdp_image_copy at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/codec/color.c:3280
 #4 gdi_bitmap_update at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/gdi/gdi.c:539
 #5 fastpath_recv_update_common at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/core/fastpath.c:236
 #6 fastpath_recv_update at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/core/fastpath.c:271
 #7 fastpath_recv_update_data at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/core/fastpath.c:409
 #8 fastpath_recv_updates at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/core/fastpath.c:517
 #9 rdp_recv_fastpath_pdu at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/core/rdp.c:1155
 #10 rdp_recv_pdu at /usr/src/debug/FreeRDP-24a752a70840f3e4b027ba7c020af71f2bcfd94a/libfreerdp/core/rdp.c:1163
Comment 1 Gerhard 2015-09-12 03:32:27 EDT
Created attachment 1072684 [details]
File: backtrace
Comment 2 Gerhard 2015-09-12 03:32:28 EDT
Created attachment 1072685 [details]
File: cgroup
Comment 3 Gerhard 2015-09-12 03:32:31 EDT
Created attachment 1072686 [details]
File: core_backtrace
Comment 4 Gerhard 2015-09-12 03:32:33 EDT
Created attachment 1072687 [details]
File: dso_list
Comment 5 Gerhard 2015-09-12 03:32:34 EDT
Created attachment 1072688 [details]
File: environ
Comment 6 Gerhard 2015-09-12 03:32:36 EDT
Created attachment 1072689 [details]
File: limits
Comment 7 Gerhard 2015-09-12 03:32:38 EDT
Created attachment 1072690 [details]
File: maps
Comment 8 Gerhard 2015-09-12 03:32:40 EDT
Created attachment 1072691 [details]
File: mountinfo
Comment 9 Gerhard 2015-09-12 03:32:42 EDT
Created attachment 1072692 [details]
File: namespaces
Comment 10 Gerhard 2015-09-12 03:32:43 EDT
Created attachment 1072693 [details]
File: open_fds
Comment 11 Gerhard 2015-09-12 03:32:44 EDT
Created attachment 1072694 [details]
File: proc_pid_status
Comment 12 Gerhard 2015-09-12 03:32:46 EDT
Created attachment 1072695 [details]
File: var_log_messages
Comment 13 Pavel Alexeev 2015-11-07 11:37:21 EST
Thank you very much for the bugreport and willing make free software better.
Could you please provide steps to reproduce that problem?
Comment 14 Gerhard 2015-12-03 03:54:09 EST
Hej Pavel,

it seems there are two problems which kills remmina.

1) Copying some text into the clipboard
2) Adjusting the resolution while connecting to a Virtualbox session running a Windows XP as guest system. I'm not 100% sure what it cause but it happens several times while connecting and unlocking the Windows session at the guest system.

Thank you take care of the problem.

Gerhard
Comment 15 Pavel Alexeev 2016-01-05 16:11:38 EST
Thank you very much for the bugreport and willing free software better.

Unfortunately most of such problems known issues. But I can't update remmina in stable Fedora branches. Details you may read in description of that copr repo https://copr.fedoraproject.org/coprs/hubbitus/remmina-next/ . It also contains fresh versions of rfeerdp and remmina. I strongly recommend you try it. You may also try install packages from rawhide (may have unstable dependencies).

If packages in copr also does not solve you problem - please leave comments and reopen issue.
Comment 16 Pavel Alexeev 2016-01-05 16:21:42 EST
*** Bug 1294603 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.