Bug 1262527 - Wrong command in the documentation in upgrade section of 1.3.0 to 1.3.1
Wrong command in the documentation in upgrade section of 1.3.0 to 1.3.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
1.3.1
x86_64 Linux
unspecified Severity high
: rc
: 1.3.1
Assigned To: ceph-docs@redhat.com
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-12 03:51 EDT by shylesh
Modified: 2015-12-18 05:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-18 05:00:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2015-09-12 03:51:22 EDT
In the document https://gitlab.cee.redhat.com/jowilkin/red-hat-ceph-storage-installation-guide-rhel/blob/v1.3/red-hat-ceph-storage-upgrade.adoc  
in the section "Upgrading v1.3.0 to v1.3.1 for ISO-based Installations" .
subsection "Monitor Nodes":- 

The command for upgrading the monitor says 



From the admin node, execute:

ceph-deploy repo ceph-mon <ceph-node>[<ceph-node> ...]
 



Running this gives the output 

[ceph@hp-ms-01-c42 ceph-config]$ ceph-deploy repo ceph-mon hp-ms-01-c41
usage: ceph-deploy [-h] [-v | -q] [--version] [--username USERNAME]
                   [--overwrite-conf] [--cluster NAME] [--ceph-conf CEPH_CONF]
                   COMMAND ...
ceph-deploy: error: argument COMMAND: invalid choice: 'repo' (choose from 'new', 'install', 'rgw', 'mds', 'mon', 'gatherkeys', 'disk', 'osd', 'admin', 'config', 'uninstall', 'purgedata', 'purge', 'forgetkeys', 'pkg', 'calamari')


Please correct the commands to 



ceph-deploy install  --repo --release=ceph-mon <ceph-node>
Comment 3 shylesh 2015-09-14 12:49:48 EDT
@Nilam,

I took ISO for 1.3.1 from this location http://download.eng.rdu2.redhat.com/nightly/Ceph-1.3-RHEL-7-20150912.n.0/compose/Installer/x86_64/iso/ 
which was latest nightly when I took it .

I mounted this ISO and below is the version of ceph-deploy shipped with this.


-r--r--r--.  14 root root  246832 Aug 14 14:25 ceph-deploy-1.5.25-3.el7cp.noarch.rpm


Can somebody confirm whether this is the right ceph-deploy version..
Comment 4 Ken Dreyer (Red Hat) 2015-09-14 13:05:59 EDT
I think I see what's happened. There's a divergence between the ceph-deploy version in RHCS 1.3.1 for RHEL and RHCS 1.3.1 for Ubuntu.

For RHEL 1.3.1, we're set to ship ceph-deploy-1.5.25-3.el7cp.

For Ubuntu 1.3.1, we're set to ship ceph-deploy v1.5.27.2.

Travis, should we ship 1.5.27.2 in RHEL, as well?
Comment 5 Travis Rhoden 2015-09-14 13:30:18 EDT
Why was the RHEL doc changed?  Was there a BZ to cover a change/mistake in the upgrade steps for RHEL?  Any change to to the docs to use "ceph-deploy repo" should have been triggered by a rebase of ceph-deploy to 1.5.27, and that has *not* happened for RHEL.

As Ken notes, the versions of ceph-deploy shipped with RHCS 1.3 is different for RHEL vs non-RHEL, and in a significant way around "repo" management.  This is less than ideal, but was necessary to handle some new repo management cases on Ubunutu that were not an issue on RHEL.

Using a newer ceph-deploy and it's repo commands has not been tested much with RHCS 1.3 on RHEL, and i do not recommend changing the ceph-deploy version for 1.3.1.

We did toss around the idea of rebasing ceph-deploy to 1.5.27 on RHEL for 1.3.2, but it does need to be a separate BZ and task because it is not an insignificant change.  It would require the code and package changes, but also doc changes (which have apparently already been made?) and testing.

Maybe I'm missing something, but this seems like we got ahead of ourselves to me.
Comment 7 shylesh 2015-09-16 07:12:36 EDT
@Nilam,

Could you please make the changes in 1.2.3 to 1.3.1 upgrade section as well.
Comment 8 Nilamdyuti 2015-09-16 08:03:09 EDT
(In reply to shylesh from comment #7)
> @Nilam,
> 
> Could you please make the changes in 1.2.3 to 1.3.1 upgrade section as well.

The changes were made to both the upgrade sections in the initial commit. Please see the 1.2.3 to 1.3.1 ISO based upgrade section.
Comment 9 shylesh 2015-10-21 03:11:45 EDT
Required changes are present in the document hence marking this as verified
Comment 10 Anjana Suparna Sriram 2015-12-18 05:00:14 EST
Fixed for 1.3.1 Release.

Note You need to log in before you can comment on or make changes to this bug.