Bug 1262559 - yumex-dnf erase wants to remove critical applications as part of it's dependencies
yumex-dnf erase wants to remove critical applications as part of it's depende...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
22
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-12 16:24 EDT by Robin Laing
Modified: 2015-10-06 05:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 05:07:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen capture of dnf erase yumex-dnf (47.54 KB, image/png)
2015-09-12 16:31 EDT, Robin Laing
no flags Details

  None (edit)
Description Robin Laing 2015-09-12 16:24:03 EDT
Description of problem:  Trying to remove


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Robin Laing 2015-09-12 16:31:16 EDT
Created attachment 1072756 [details]
Screen capture of dnf erase yumex-dnf

This is from a 32 bit machine.  The kernel being removed is an old kernel but still shouldn't be included.
Comment 2 Robin Laing 2015-09-12 16:36:07 EDT
For some reason, the entry was saved before I had entered all the data.

While trying to diagnose and report issues with yumex-dnf, I was going to remove it and re-install.  During the removal, included applications being removed during the function were critical to operation.  Tried on a 32 and 64 bit machines.  Different dependencies.

Tried this on two different machines with different responses.

I have uploaded a screen capture of the issue.  Removing a kernel, even old is not a thing to see if removing an application not involved with the kernel.

Also, should dnfdaemon be part of the packages removed?


On the 64 bit machine, sorry, no screen capture.  SELINUX related tools are being removed.  This is concerning from a security point of view.

audit-libs-python
checkpolicy
policycoreutils-python
libsemanager-python
setools-libs
Comment 3 Tim Lauridsen 2015-10-06 05:07:17 EDT
This is a feature of dnf, to automatic remove leftover packages like old kernel versions, it has nothing to do with yumex-dnf

Note You need to log in before you can comment on or make changes to this bug.