Bug 1262596 - Ironic-API seems to be unresponsive and cause installation / introspection to fail
Ironic-API seems to be unresponsive and cause installation / introspection t...
Status: CLOSED DUPLICATE of bug 1246525
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity urgent
: z3
: 7.0 (Kilo)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-13 03:34 EDT by Ofer Blaut
Modified: 2015-09-28 07:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 07:49:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
API traceback (3.50 KB, text/plain)
2015-09-13 03:34 EDT, Ofer Blaut
no flags Details
logs (7.31 MB, application/x-gzip)
2015-09-13 03:37 EDT, Ofer Blaut
no flags Details

  None (edit)
Description Ofer Blaut 2015-09-13 03:34:34 EDT
Created attachment 1072830 [details]
API traceback

Description of problem:


[root@puma33 stack]# grep -i haproxy /var/log/messages
Sep 13 09:56:40 puma33 haproxy[17181]: Server ironic/192.0.2.1 is DOWN, reason: Layer7 timeout, check duration: 10001ms. 0 active and 0 backup servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
Sep 13 09:56:40 puma33 haproxy[17181]: proxy ironic has no server available!
Sep 13 09:58:14 puma33 haproxy[17181]: Server ironic/192.0.2.1 is UP, reason: Layer7 check passed, code: 200, info: "OK", check duration: 9105ms. 1 active and 0 backup servers online. 0 sessions requeued, 0 total in queue.






Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ofer Blaut 2015-09-13 03:37:38 EDT
Created attachment 1072831 [details]
logs
Comment 2 Ofer Blaut 2015-09-13 03:44:08 EDT
(In reply to Ofer Blaut from comment #0)
> Created attachment 1072830 [details]
> API traceback
> 
> Description of problem:

overcloud  deployment  failed because of 0 nodes, while i had 6 discovered by ironic.

Logs are attached 

> 
> 
> [root@puma33 stack]# grep -i haproxy /var/log/messages
> Sep 13 09:56:40 puma33 haproxy[17181]: Server ironic/192.0.2.1 is DOWN,
> reason: Layer7 timeout, check duration: 10001ms. 0 active and 0 backup
> servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
> Sep 13 09:56:40 puma33 haproxy[17181]: proxy ironic has no server available!
> Sep 13 09:58:14 puma33 haproxy[17181]: Server ironic/192.0.2.1 is UP,
> reason: Layer7 check passed, code: 200, info: "OK", check duration: 9105ms.
> 1 active and 0 backup servers online. 0 sessions requeued, 0 total in queue.
> 
> 
> 
> 
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:
Comment 3 Ofer Blaut 2015-09-13 03:52:39 EDT
(In reply to Ofer Blaut from comment #0)
> Created attachment 1072830 [details]
> API traceback
> 
> Description of problem:

overcloud deployment fails since there are NO nodes found .
Error to the screen tell haproxy has not ironic server found 
> 
> 
> [root@puma33 stack]# grep -i haproxy /var/log/messages
> Sep 13 09:56:40 puma33 haproxy[17181]: Server ironic/192.0.2.1 is DOWN,
> reason: Layer7 timeout, check duration: 10001ms. 0 active and 0 backup
> servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
> Sep 13 09:56:40 puma33 haproxy[17181]: proxy ironic has no server available!
> Sep 13 09:58:14 puma33 haproxy[17181]: Server ironic/192.0.2.1 is UP,
> reason: Layer7 check passed, code: 200, info: "OK", check duration: 9105ms.
> 1 active and 0 backup servers online. 0 sessions requeued, 0 total in queue.
> 
> 
> 
> 
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:
Comment 4 chris alfonso 2015-09-14 12:06:50 EDT
Are there any steps to reproduce this outside of the normal flow of installation?
Comment 6 Ofer Blaut 2015-09-16 07:44:59 EDT
No, Just install and check logs 
It happnes from time to time
Comment 8 Ofer Blaut 2015-09-16 07:58:18 EDT
*** Bug 1263645 has been marked as a duplicate of this bug. ***
Comment 9 James Slagle 2015-09-28 07:49:51 EDT

*** This bug has been marked as a duplicate of bug 1246525 ***

Note You need to log in before you can comment on or make changes to this bug.