Bug 1262600 - Plasma live session notifies for available updates
Summary: Plasma live session notifies for available updates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spin-kickstarts
Version: 23
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jeroen van Meeuwen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F23FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-09-13 09:41 UTC by Giulio 'juliuxpigface'
Modified: 2015-10-22 19:16 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-22 19:16:58 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 353962 0 None None None Never

Description Giulio 'juliuxpigface' 2015-09-13 09:41:20 UTC
Description of problem:
During the installation of the compose Fedora-Live-KDE-i686-23_Beta-TC5.iso on qemu-kvm, I received a notify from the Plasma applet. It said that there were some updates available.


Version-Release number of selected component (if applicable):
plasma-pk-updates-0.2-3.fc23.i686


How reproducible:
Always (I haven't tried with the x86_64 compose, yet).


Steps to Reproduce:
1. Boot the live Fedora-Live-KDE-i686-23_Beta-TC5.iso.
2. Wait for a reasonable amount of time.


Actual results:
1. Notifies about updates are displayed in both live and installed system.


Expected results:
1. According to Final Release Criteria 2.4.8 (https://fedoraproject.org/wiki/Fedora_22_Final_Release_Criteria#Update_notification), notifies about updates should only be displayed in the installed system.


Additional info:
In my opinion, there might be a regression somewhere. There was an old report for this (see bug https://bugzilla.redhat.com/show_bug.cgi?id=1206760). I decided to open a new report, because:
1. It may be a brand new issue and not a regression.
1. The old one originally was opened in order to report another problem: notifies were missing from the installed system. In this new case, notifies are correctly displayed on the installed system.
2. The old one refers to the F22 cycle.
3. The old one had lots of comments, which might be not so useful if this new issue is significantly different.

Comment 1 Fedora Blocker Bugs Application 2015-09-13 10:06:54 UTC
Proposed as a Blocker for 23-final by Fedora user juliuxpigface using the blocker tracking app because:

 Proposed as Final Blocker, because this seems to violate the following criteria: 2.4.8 Update notification (https://fedoraproject.org/wiki/Fedora_23_Final_Release_Criteria#Update_notification)

"Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image."

Comment 2 Rex Dieter 2015-09-14 14:00:50 UTC
Not sure how this isn't working anymore, from 
https://git.fedorahosted.org/cgit/spin-kickstarts.git/tree/fedora-live-kde-base.ks :

# Disable plasma-pk-updates
sed -i \
    -e "s|^X-KDE-PluginInfo-EnabledByDefault=true|X-KDE-PluginInfo-EnabledByDefault=false|g" \
    /usr/share/kservices5/plasma-applet-org.kde.plasma.pkupdates.desktop

Comment 3 Adam Williamson 2015-09-14 16:44:44 UTC
Discussed at 2015-09-14 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-14/f23-blocker-review.2015-09-14-16.00.log.txt . Accepted as a blocker per criterion cited in #c1.

Comment 4 satellitgo 2015-09-14 16:49:54 UTC
I also see this in virt-manager f23   f23 kde live beta tc-5 x86_64 live checks for updates and notifies for 151 updates

Comment 5 Rex Dieter 2015-09-22 13:35:09 UTC
Seems the initial login to plasma that one cannot configure visible systray applets.

right click systray -> system tray settings -> general(section-> extra items

all of them appear to be unchecked, and no changes made there do anything.

This works as expected on subsequent logins.  (once you workaround logind previous lingering login session, but that's a separate issue)


I confirmed this both for live image, and installed versions.

Comment 6 satellitgo 2015-10-14 22:15:45 UTC
seen in boot of gnome-disks USB boot of Fedora-Live-KDE-i686-23-TC9.iso as live usb. also as

installed to HD: notifies and installs updates

Comment 7 Rex Dieter 2015-10-16 13:09:37 UTC
Filed bug upstream,
https://bugs.kde.org/show_bug.cgi?id=353962

Comment 8 Than Ngo 2015-10-19 21:13:53 UTC
Rex, i think we can use this js script to disable it for live image

pids = panelIds;
for (i = 0; i < pids.length; ++i) { //search through the panels
  panel = panelById(pids[i]);
  if (!panel) continue;
  ids = panel.widgetIds;
  for (j = 0; j < ids.length; ++j) { //search through the widgets for systray
    widget = panel.widgetById(ids[j]);
    if (!widget || widget.type != "systemtray") {
      continue;
    }
    //widget var is now the systray
    widget.currentConfigGroup = Array("Applets");
    noOfApplets = widget.configGroups.length;
    var groups = new Array();
    for (k = 0; k < noOfApplets; ++k) {
      groups.push(widget.configGroups[k])
    }
    for (k = 0; k < noOfApplets; ++k) {
      widget.currentConfigGroup = new Array("Applets", groups[k]);
      if (widget.readConfig("plugin") == "org.kde.plasma.pkupdates") {
        widget.writeConfig("plugin",""); //found it at last, wipe it blank
      }
    }
  }
}

Comment 9 Than Ngo 2015-10-19 22:09:11 UTC
i created a fix for this issue. I already tested it and it works fine.

cat spin-kickstarts-kde-disable-pkupdates.patch

diff -up spin-kickstarts-0.24.0/fedora-live-kde-base.ks.than spin-kickstarts-0.24.0/fedora-live-kde-base.ks
--- spin-kickstarts-0.24.0/fedora-live-kde-base.ks.than 2015-10-19 23:47:04.603996818 +0200
+++ spin-kickstarts-0.24.0/fedora-live-kde-base.ks      2015-10-19 23:47:54.351685132 +0200
@@ -82,8 +82,8 @@ AKONADI_EOF
 
 # Disable plasma-pk-updates
 sed -i \
-    -e "s|^X-KDE-PluginInfo-EnabledByDefault=true|X-KDE-PluginInfo-EnabledByDefault=false|g" \
-    /usr/share/kservices5/plasma-applet-org.kde.plasma.pkupdates.desktop
+    -e "s|^X-KDE-PluginInfo-EnabledByDefault=true||g" \
+    /usr/share/plasma/plasmoids/org.kde.plasma.pkupdates/metadata.desktop
 
 # Disable baloo
 cat > /home/liveuser/.config/baloofilerc << BALOO_EOF


i also did a scratch build
 http://koji.fedoraproject.or/koji/taskinfo?taskID=11505959
because i dont have permssion to commit the fix. Please test it!!

Comment 10 Than Ngo 2015-10-19 22:19:02 UTC
add correct url
http://koji.fedoraproject.org/koji/taskinfo?taskID=11505960

Comment 11 Kevin Kofler 2015-10-19 22:36:17 UTC
The script from comment #8 will not work, that way of controlling systray applets only works in Plasma 4. The patch from comment #9 looks like it may work (as a workaround – it sure doesn't fix the real issue [http://bugs.kde.org/show_bug.cgi?id=353962], which must be somewhere in C++ and/or QML code). So if the comment #9 patch works for you, I guess we can use that. (Unfortunately, the blocker process encourages quick hacks instead of real fixes. :-( )

Comment 12 Adam Williamson 2015-10-19 23:32:53 UTC
the release process requires a releasable level of quality. how you achieve that is between you, your upstream, your conscience and your deity...we *did* report and approve this as a blocker over a month ago, you had all that time to work on 'real fixes'.

thanks for the patch, I'll test it out.

Comment 13 Adam Williamson 2015-10-20 01:14:53 UTC
Fix is looking good here, live image doesn't check updates, installed system does.

Worryingly, my installed KVM booted to a black screen twice before I got it to boot to SDDM, but this issue looks good. Kevin, do you want to apply the change to spin-kickstarts git?

Comment 14 Than Ngo 2015-10-20 07:55:17 UTC
yes, it's a workaround for this issue. But it's good enough to add it in f23 release.

Comment 15 Than Ngo 2015-10-20 07:56:58 UTC
if someone can give the permission to commit the change to spin-kickstarts git, i can apply it and build it in f23

Comment 16 Rex Dieter 2015-10-20 13:24:14 UTC
Interesting, I thought I had even tested the case of removing the .desktop file completely and the sucker had still loaded.

I'll commit the workaround asap

Comment 17 Rex Dieter 2015-10-20 13:44:22 UTC
OK, my prior comment was misguided, missed initially that the .desktop file being modified was different.

Tested a slightly different variant, with same positive results,
https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f23&id=21a379ef79a61d1f4a602471e6fc66ea21b67df7

Comment 18 Adam Williamson 2015-10-20 18:47:38 UTC
OK, counting as ON_QA, we will verify fix with RC1 when it comes.

Comment 19 Kamil Páral 2015-10-22 10:48:32 UTC
I have waited about 15 minutes in RC2 KDE, no notification. Seems fixed.

Comment 20 Adam Williamson 2015-10-22 19:16:58 UTC
There's no package to push, here, we can just close it.


Note You need to log in before you can comment on or make changes to this bug.