Bug 1262601 - apps-menu items will not highlight
apps-menu items will not highlight
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell-extensions (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-13 05:47 EDT by rudolf
Modified: 2017-08-01 18:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:41:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 754959 None None None Never

  None (edit)
Description rudolf 2015-09-13 05:47:21 EDT
Description of problem:

Submenu items will sometimes not highlight when pointing mouse cursor over them.


Version-Release number of selected component (if applicable):

Name        : gnome-shell-extension-apps-menu
Arch        : noarch
Version     : 3.14.4
Release     : 9.el7


Steps to Reproduce:
1. click Applications
2. move mouse to Favorites
3. move mouse to right, over first sub-menu item


Actual results:

Menu item is not highlighted 50% of time, but clicking on item opens application correctly.


Expected results:

Highligting should be more reliable.
Comment 1 Matthias Clasen 2015-09-22 13:25:31 EDT
seems to be only the first time you enter the submenu, after the open submenu changed, and only for the item you enter initially. As soon as you veer over another item in the submenu, the selection is shown.
Comment 2 rudolf 2015-09-22 14:25:29 EDT
Yes, your description is 100% accurate.

I think that clicking on non highlighted menu item is somewhat mentally confusing :)

It's present in all Gnome versions since 3.8, including 3.17 beta.
I reported bug in upstream https://bugzilla.gnome.org/show_bug.cgi?id=754959
Comment 3 Matthias Clasen 2015-09-22 15:21:42 EDT
thanks for the upstream bug. given that this has been present for a long time (thus not a regression), I'll move this bug to 7.3.
Comment 4 rudolf 2015-10-07 17:52:22 EDT
Patch is available upstream, would be nice to have this extension fixed in 7.2
Comment 5 Florian Müllner 2015-10-08 07:32:30 EDT
(In reply to rudolf from comment #4)
> Patch is available upstream, would be nice to have this extension fixed in
> 7.2

At this point, only blocker bugs are considered for 7.2. However we should include the fix in RHEL 7.3.
Comment 8 Michael Boisvert 2017-06-06 16:33:34 EDT
I highlighted Application menu items for a considerable amount of time and had 100% consistency.
Comment 9 errata-xmlrpc 2017-08-01 18:41:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2098

Note You need to log in before you can comment on or make changes to this bug.