This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1262605 - libattr-devel Requires: man-pages - WHY?
libattr-devel Requires: man-pages - WHY?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: attr (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-13 06:39 EDT by Harald Reindl
Modified: 2015-10-05 18:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.4.47-14.fc23 attr-2.4.47-10.fc22 attr-2.4.47-10.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 00:11:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2015-09-13 06:39:57 EDT
why in the world would i need that on a build-machine?
i can read manpages on my desktop pretty fine.........
_____________________________________________________

frankly that was manually added in the SPEC file for no good reason

%package -n libattr-devel
Summary: Files needed for building programs with libattr
Group: Development/Libraries
License: LGPLv2+
Requires: libattr = %{version}-%{release}

# provides {,f,l}{get,list,remove,set}xattr.2 man pages
Requires: man-pages
_____________________________________________________

[root@buildserver64:~]$ yum remove man-pages
Loaded plugins: protectbase, tsflags
Resolving Dependencies
--> Running transaction check
---> Package man-pages.noarch 0:3.69-5.fc21 will be erased
--> Processing Dependency: man-pages for package: libattr-devel-2.4.47-9.fc21.x86_64
--> Running transaction check
---> Package libattr-devel.x86_64 0:2.4.47-9.fc21 will be erased
--> Processing Dependency: libattr-devel for package: libacl-devel-2.2.52-7.fc21.x86_64
--> Running transaction check
---> Package libacl-devel.x86_64 0:2.2.52-7.fc21 will be erased
--> Processing Dependency: libacl-devel for package: lounge-build-requires-21.0-2.fc21.20150714.rh.noarch
--> Running transaction check
Comment 1 Harald Reindl 2015-09-13 06:41:59 EDT
and BTW the useless of this dependency is proven by "tsflags=nodocs" in yum.conf by using "yum-plugin-tsflags" which finally renders any file of the man-pages package at only present in the rpmdb but not on the filesystem
Comment 2 Kamil Dudka 2015-09-14 03:47:59 EDT
(In reply to Harald Reindl from comment #0)
> why in the world would i need that on a build-machine?

-devel packages are supposed to install the related API documentation (unless it is big enough to be split to the -docs subpackage).

> i can read manpages on my desktop pretty fine.........
> _____________________________________________________
> 
> frankly that was manually added in the SPEC file for no good reason

I believe the reason is pretty obvious from the comment.  You can get more info from git-blame and the related thread on upstream mailing-list:

http://lists.nongnu.org/archive/html/acl-devel/2014-03/msg00010.html

Prior to the change, {,f,l}{get,list,remove,set}xattr.2 man pages were installed by the libattr-devel sub-package.  So the dependency was added to keep those man pages installed when libattr-devel is installed.
Comment 3 Harald Reindl 2015-09-14 04:09:55 EDT
the dependency "man-pages" is completly useless, on any default install it's present anyways and if soembody decides to uninstall it while have a lot of devel-packages on the machine and only one of them pulls a 5 MB not needed and removed by intention package is only rude - period

the word "dependency" has a clear meaning, the devel pakcage *do not* depend on man-pages, period
Comment 4 Kamil Dudka 2015-09-14 04:18:49 EDT
Thanks for the explanation!  I will remove the dependency to make the minimal buildroot smaller.  Perhaps this is a use case that RPM weak dependencies intend to cover?
Comment 5 Kamil Dudka 2015-09-14 06:08:35 EDT
Harald, does this work for you?

--- a/attr.spec
+++ b/attr.spec
@@ -41,7 +41,7 @@ License: LGPLv2+
 Requires: libattr = %{version}-%{release}

 # provides {,f,l}{get,list,remove,set}xattr.2 man pages
-Requires: man-pages
+Recommends: man-pages

 %description -n libattr-devel
 This package contains header files and documentation needed to
Comment 6 Harald Reindl 2015-09-14 06:17:32 EDT
not sure how far the support for weak dependencies currently is, but sounds good, would you mind to offer somewhere a rpm-build with this change for F21 and/or F22?
Comment 7 Kamil Dudka 2015-09-14 06:27:51 EDT
This would be for rawhide only.  I am not going to mess stable Fedora with the weak dependency.  If your concern is about Fedora 21..23, I think just removing the dependency is a better choice.
Comment 8 Harald Reindl 2015-09-14 06:29:14 EDT
well, there is a reaosn why i selected 21 as version while write the bugreport :-)
Comment 9 Kamil Dudka 2015-09-14 06:50:19 EDT
I see.  The question is whether the solution proposed for rawhide works in your case, so that we do not have a fresh bug report when f24 becomes stable.  Could you please try the following scratch build?

http://koji.fedoraproject.org/koji/taskinfo?taskID=11078771
Comment 10 Harald Reindl 2015-09-14 07:03:39 EDT
as expected, i can remove man-pages

Sep 14 13:02:46 Updated: libattr-2.4.47-14.fc21.x86_64
Sep 14 13:02:46 Updated: attr-2.4.47-14.fc21.x86_64
Sep 14 13:02:47 Updated: libattr-devel-2.4.47-14.fc21.x86_64
Sep 14 13:02:57 Erased: man-pages-3.69-5.fc21.noarch
Comment 11 Kamil Dudka 2015-09-14 07:18:26 EDT
fixed in attr-2.4.47-14.fc24
Comment 12 Fedora Update System 2015-09-14 07:34:38 EDT
attr-2.4.47-10.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15810
Comment 13 Fedora Update System 2015-09-14 07:34:42 EDT
attr-2.4.47-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15812
Comment 14 Fedora Update System 2015-09-14 13:50:32 EDT
attr-2.4.47-14.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update attr'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15812
Comment 15 Fedora Update System 2015-09-14 20:20:10 EDT
attr-2.4.47-10.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update attr'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15811
Comment 16 Fedora Update System 2015-09-15 01:55:25 EDT
attr-2.4.47-10.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update attr'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15810
Comment 17 Fedora Update System 2015-09-23 00:11:15 EDT
attr-2.4.47-14.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-09-27 11:49:49 EDT
attr-2.4.47-10.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2015-10-05 18:52:55 EDT
attr-2.4.47-10.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.