Bug 1262617 - virtualbox guest additions
virtualbox guest additions
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-13 09:59 EDT by Richard S. Hendershot
Modified: 2015-10-03 08:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 11:30:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemctl run wild (55.93 KB, text/plain)
2015-09-16 10:45 EDT, Richard S. Hendershot
no flags Details
processes end but this one (7992) never completes (218 bytes, text/plain)
2015-09-16 10:48 EDT, Richard S. Hendershot
no flags Details
another vboxadd that starves (54.91 KB, text/plain)
2015-09-16 10:50 EDT, Richard S. Hendershot
no flags Details
the script to create the logs (59 bytes, application/x-shellscript)
2015-09-16 10:54 EDT, Richard S. Hendershot
no flags Details

  None (edit)
Description Richard S. Hendershot 2015-09-13 09:59:54 EDT
Description of problem:  can't install virtualbox guest additions


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. install
2. mount additions
3. run

Actual results: systemctl vbox-add goes wild, memory is sucked up, systemd runs cpu to max


Expected results: successful 'starting guest additions'


Additional info:
Comment 1 Jan Synacek 2015-09-15 03:55:39 EDT
There is no systemctl vbox-add.
Comment 2 Richard S. Hendershot 2015-09-16 10:45:50 EDT
Created attachment 1074064 [details]
systemctl run wild

I apologize for not being able to remember the exact log but this shows the many forks that result in memory starvation.  VM is given 2G RAM
Comment 3 Richard S. Hendershot 2015-09-16 10:48:31 EDT
Created attachment 1074065 [details]
processes end but this one (7992) never completes

I kill this process and vbox additions continues. I have to do this several times.
Comment 4 Richard S. Hendershot 2015-09-16 10:50:45 EDT
Created attachment 1074066 [details]
another vboxadd that starves

during this time systemd is running 100%
Comment 5 Richard S. Hendershot 2015-09-16 10:52:07 EDT
I think there is a problem.  I may not have captured anything useful but any guidance in that is welcomed.  Pls advise.
Comment 6 Richard S. Hendershot 2015-09-16 10:54:54 EDT
Created attachment 1074070 [details]
the script to create the logs
Comment 7 Richard S. Hendershot 2015-09-26 09:30:51 EDT
still cannot install virtual box additions.  increased VM memory to 4G.  

[]$ ./chk_systemctl 
root      7189  1932  0 08:22 pts/1    00:00:00 systemctl start vboxadd
rhender+  7248  1732  0 08:29 pts/0    00:00:00 /bin/sh ./chk_systemctl
rhender+  7250  7248  0 08:29 pts/0    00:00:00 grep -i systemctl
-------
              total        used        free      shared  buff/cache   available
Mem:           3952         642        2861           9         448        3225
Swap:          1999           0        1999
Comment 8 Adam Williamson 2015-09-28 11:30:05 EDT
Hi Richard! As I explained on IRC, this looks like a real problem, but likely not a problem in Fedora. vboxadd-service.service is coming from VirtualBox, not from anything in Fedora, and it seems like that's where the problem is.

I recommend you report this to wherever you got your VirtualBox from.
Comment 9 Richard S. Hendershot 2015-10-03 08:13:33 EDT
Thanks again for all's help.  This is fixed in VirtualBox 5.0.6 re: their bug 14571

Note You need to log in before you can comment on or make changes to this bug.