Bug 1262681 - rescheduling remote command action scheduled by SSM on failing system
rescheduling remote command action scheduled by SSM on failing system
Status: CLOSED DUPLICATE of bug 1252166
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Red Hat Satellite QA List
Depends On:
  Show dependency treegraph
Reported: 2015-09-14 01:59 EDT by Jan Hutař
Modified: 2015-09-18 10:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-09-14 05:29:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-09-14 01:59:15 EDT
Description of problem:
Schedule remote command action on multiple systems using SSM and when it fails on some of them, use "Reschedule" button on individual server page and notice that it reschedules the action on all of the servers from initial set.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Register 2 clients and add "Provisioning" add on entitlements to them
2. Make sure clients have remote actions enabled
   # rhn-actions-control --enable-run
3. Using SSM, schedule remote command action which fails on one of
   systems, like:
   # hostname | grep 'unique_part_of_hostname_of_one_system'
4. Run `rhn_check -vv` on both systems so the action is picked:
   D: do_call script.run(105670, {'username': 'root', 'groupname': 'root', 'now': '2015-09-14 01:23:25', 'timeout': 600, 'script': '#!/bin/sh\nhostname | grep unique_part_of_hostname_of_one_system'}){'cache_only': None}
   D: Sending back response(...
5. Go to Systems -> system where it failed -> Events -> History -> failed
   action and click "Reschedule" button

Actual results:
Notice that action is rescheduled on the system it passed as well.

Expected results:
Maybe there should be way how to reschedule only failing systems, or we should be more clear that this button (which is tied to individual system) reschedules action on *all* systems.
Comment 2 Jan Hutař 2015-09-14 05:29:05 EDT

*** This bug has been marked as a duplicate of bug 1252166 ***

Note You need to log in before you can comment on or make changes to this bug.