Bug 1262685 - sssd-tools should be moved from Optional to base
sssd-tools should be moved from Optional to base
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng (Show other bugs)
7.3
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Jan Blazek
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 02:07 EDT by Jakub Hrozek
Modified: 2015-11-19 02:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:54:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2015-09-14 02:07:24 EDT
Description of problem:
The sssd-tools package is in the Optional channel. However, we're adding features to the package, which means customers will be looking for it.

We need to move the sssd-tools package from optional to base.

Version-Release number of selected component (if applicable):
as of 7.2 beta
Comment 2 Jakub Hrozek 2015-09-17 07:10:37 EDT
Ping, any chance of doing this in 7.2 ?
Comment 3 Jan Blazek 2015-09-17 07:22:18 EDT
(In reply to Jakub Hrozek from comment #2)
> Ping, any chance of doing this in 7.2 ?

If this bug gets all the required flags including exception or blocker then yes.
Comment 7 Jan Blazek 2015-09-23 04:52:16 EDT
There are separate optional repos per each variant/architecture.

What non-optional variants/architectures are desired?

What for is actually sssd-tools needed? Is that kind of weak dependency of another package? (from the functional point of view, rpm actually doesn't support weak dependencies)

Client-optional/x86_64
ComputeNode-optional/x86_64
Server-optional/aarch64
Server-optional/ppc64
Server-optional/ppc64le
Server-optional/s390x
Server-optional/x86_64
Workstation-optional/x86_64
Comment 8 Jakub Hrozek 2015-09-23 06:36:27 EDT
(In reply to Jan Blazek from comment #7)
> There are separate optional repos per each variant/architecture.
> 
> What non-optional variants/architectures are desired?
> 

I would say all, because all can very reasonably be a domain member.

> What for is actually sssd-tools needed? Is that kind of weak dependency of
> another package? (from the functional point of view, rpm actually doesn't
> support weak dependencies)
> 

See comment #5. As per dependencies, it's not a dependency, it's an feature itself. (Obviously requires sssd up and running)

> Client-optional/x86_64
> ComputeNode-optional/x86_64
> Server-optional/aarch64
> Server-optional/ppc64
> Server-optional/ppc64le
> Server-optional/s390x
> Server-optional/x86_64
> Workstation-optional/x86_64
Comment 9 Jan Blazek 2015-09-23 07:06:02 EDT
Added to 'Directory Client' comps group which is on all variants/architectures.

diff --git a/comps-rhel-7.2.xml b/comps-rhel-7.2.xml
index 313ddff..75d3711 100644
--- a/comps-rhel-7.2.xml
+++ b/comps-rhel-7.2.xml
@@ -1734,6 +1734,7 @@
       <packagereq type="optional">samba-winbind</packagereq>
       <packagereq type="optional">samba-winbind-clients</packagereq>
       <packagereq type="optional">sssd-dbus</packagereq>
+      <packagereq type="optional">sssd-tools</packagereq>
     </packagelist>
   </group>
   <group>
Comment 13 errata-xmlrpc 2015-11-19 02:54:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2107.html

Note You need to log in before you can comment on or make changes to this bug.