Bug 1262687 - dnf informs about skipping src packages
dnf informs about skipping src packages
Status: CLOSED DUPLICATE of bug 1255569
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-09-14 02:10 EDT by Daniel Mach
Modified: 2015-09-16 10:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-09-16 10:21:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2015-09-14 02:10:02 EDT
$ dnf update
Skipping packages with broken dependencies:                                                                                                                                                  
 patternfly2                                         src                          2.2.0-1.fc23                                            patternfly-patternfly2                       3.9 M

[installing updates]

^^^ dnf offered *src* instead of noarch package! ^^^

$ rpm -q patternfly2

$ dnf update
[nothing happened, dnd did *not* say anything about patternfly2]
Comment 1 Radek Holy 2015-09-14 03:58:10 EDT
I'd mark this as a duplicate of the bug 1255569. I suspect that the missing "paternfly2" in the second run is caused by the installed updates during the first run but it's hard to guess since the bug report is too brief...
Comment 2 Daniel Mach 2015-09-14 09:50:47 EDT
I think these might be the same bugs.
In either case, it deserves to be fixed, not closed NOTABUG.
Dnf should not offer src packages as updates to existing arch/noarch packages.
Comment 3 Radek Holy 2015-09-15 05:05:31 EDT
DNF did not offer an upgrade to a src package. It skipped that package.
Comment 4 Radek Holy 2015-09-16 10:21:26 EDT

*** This bug has been marked as a duplicate of bug 1255569 ***

Note You need to log in before you can comment on or make changes to this bug.