Bug 1262689 - [abrt] tracer: _pslinux.py:706:wrapper:NoSuchProcess: process no longer exists (pid=23220)
[abrt] tracer: _pslinux.py:706:wrapper:NoSuchProcess: process no longer exist...
Status: CLOSED DUPLICATE of bug 1215561
Product: Fedora
Classification: Fedora
Component: tracer (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:b82bca08df040d6d846ff8de255...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 02:17 EDT by Davide Repetto
Modified: 2015-09-14 06:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 06:06:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.56 KB, text/plain)
2015-09-14 02:17 EDT, Davide Repetto
no flags Details
File: environ (3.08 KB, application/octet-stream)
2015-09-14 02:17 EDT, Davide Repetto
no flags Details

  None (edit)
Description Davide Repetto 2015-09-14 02:17:30 EDT
Version-Release number of selected component:
tracer-0.6.3-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /bin/tracer -n python-slip dbusmenu-qt5 python3-slip-dbus python-slip-dbus python3-slip python-slip-gtk dbusmenu-qt bash
dso_list:       python-psutil-2.1.3-1.fc22.x86_64
executable:     /bin/tracer
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
_pslinux.py:706:wrapper:NoSuchProcess: process no longer exists (pid=23220)

Traceback (most recent call last):
  File "/bin/tracer", line 34, in <module>
    tracer.main.run()
  File "/usr/lib/python2.7/site-packages/tracer/main.py", line 42, in run
    return router.dispatch()
  File "/usr/lib/python2.7/site-packages/tracer/resources/router.py", line 55, in dispatch
    controller = DefaultController(self.args, self.packages)
  File "/usr/lib/python2.7/site-packages/tracer/controllers/default.py", line 61, in __init__
    self.applications = self.tracer.trace_affected(self._user(args.user))
  File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 107, in trace_affected
    p = self._apply_rules(p)
  File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 125, in _apply_rules
    p_rule = self._rules.find(parent.name())
  File "/usr/lib/python2.7/site-packages/tracer/resources/processes.py", line 67, in name
    return self._attr("name")
  File "/usr/lib/python2.7/site-packages/tracer/resources/processes.py", line 93, in _attr
    try: return attr()
  File "/usr/lib64/python2.7/site-packages/psutil/__init__.py", line 489, in name
    name = self._proc.name()
  File "/usr/lib64/python2.7/site-packages/psutil/_pslinux.py", line 706, in wrapper
    raise NoSuchProcess(self.pid, self._name)
NoSuchProcess: process no longer exists (pid=23220)

Local variables in innermost frame:
fun: <function name at 0x7f88d61a3668>
self: <psutil._pslinux.Process object at 0x7f88d4a3fa90>
args: ()
err: IOError(2, 'No such file or directory')
kwargs: {}
Comment 1 Davide Repetto 2015-09-14 02:17:34 EDT
Created attachment 1073067 [details]
File: backtrace
Comment 2 Davide Repetto 2015-09-14 02:17:35 EDT
Created attachment 1073068 [details]
File: environ
Comment 3 Jakub Kadlčík 2015-09-14 06:06:05 EDT
Hello Davide,
thank you for the feedback.

This is duplicate of 1215561, so I am closing this issue and please see the progress on the referenced one.

*** This bug has been marked as a duplicate of bug 1215561 ***

Note You need to log in before you can comment on or make changes to this bug.