Bug 126269 - When default language is British English, Slashdot login form broken in all browsers
When default language is British English, Slashdot login form broken in all b...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
http://slashdot.org/login.pl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 05:16 EDT by Adrianna Pinska
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 10:55:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrianna Pinska 2004-06-18 05:16:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Galeon/1.3.14

Description of problem:
I set the default language to British English during installation on
two machines, at home and at work.  Some time later, I found that I
was unable to log in to Slashdot, although I was absolutely certain
that the password I was entering was correct, and the cookie
permissions were correct.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set default language to British English
2. Go to Slashdot
3. Try to log in using the form.
    

Actual Results:  I got redirected to the login error form, where my
user name was filled in and the password field was empty.

Expected Results:  I should have been logged in.

Additional info:

At first I thought it was a form bug in Galeon or Mozilla, but I
determined the folowing:

* The actual login URL which contains the GET variables works fine. 
However, the login form does not appear to submit the variables correctly.
* Exactly the same thing happens in lynx and w3m.
* Everything was fine on another machine with identical installation
settings except for the language, and when the default language on the
problem machine was changed to US English, everything was fine.

So it looks like changing the language does something weird to the
character encoding, or something similar.
Comment 1 Adrianna Pinska 2004-06-18 05:33:41 EDT
(I'm not sure whether this is Slashdot's fault or Fedora's fault - I
am also filing this at the Slash bug tracker.)
Comment 2 Brent Fox 2004-06-23 18:55:37 EDT
Are you also using the UK keymap or are you using a US keymap?  I
can't imagine that just the language setting alone would cause this
problem.  
Comment 3 Adrianna Pinska 2004-06-24 05:02:36 EDT
I think it was the default US keymap, unless this is overridden by the
language setting.

My password doesn't contain any weird characters - it's all letters
and numbers.

I've realised that something else on Slashdot which has fixed itself
now that I have changed the language setting is the posting form -
before, I couldn't preview (the POST arguments would get lost) and my
line breaks wouldn't register as line breaks in plain text mode.

I never noticed any other strange issues related to typing characters.

I had no problems logging in on any other site (not even Kuro5hin,
which also uses Slash - although I think they use a different
flavour).  But I don't have accounts on many sites - perhaps five in
total - and don't fill in forms very often, so this isn't really
conclusive.
Comment 4 Adrianna Pinska 2004-06-24 05:07:26 EDT
Now that I think of it, the newlines were probably being ignored as a
result of the form not registering that I had selected plain text
format - the default is HTML - and not because there was something
weird about my line breaks.

I could actually *post* the post, though.
Comment 5 Adrianna Pinska 2004-06-24 06:33:28 EDT
OK, I have done some experimentation.  It is not the language itself
(when I change the LANG variable from en_US.UTF-8 to en_GB.UTF-8 and
try a console browser, it's fine).  But I don't think it's the
keyboard either - when I change the language through the gui and go to
the keyboard settings dialog, the keymap seems still to be set to US
English.

So what else does redhat-config-language change?

(By the way, I have confirmed that the same things happen whether I
change the default system language under system settings or change the
language for the session before logging in.)
Comment 6 Brent Fox 2004-06-24 10:20:54 EDT
All redhat-config-language changes is the fields in
/etc/sysconfig/i18n.  The keymap is not changed by this. 
redhat-config-keyboard changes the keymap in both X and the console.  
Comment 7 Paul Nasrat 2004-08-19 06:37:54 EDT
I can't replicate this in the slightest, I have a British Keyboard
setup and am usinng en_US.UTF-8 on Fedora Core 2.  Mozilla happily
logs in for me.

Can you confirm if this issue persisits for you in Fedora Core 2 or
Fedora Core 3 test 1?
Comment 8 Adrianna Pinska 2004-08-19 06:47:26 EDT
I am currently still using Fedora Core 1, but I am planning to switch
to Core 2 soon.  If I experience the same problem, I will report it.
Comment 9 Paul Nasrat 2004-11-23 10:55:56 EST
Closing as worked for me

Note You need to log in before you can comment on or make changes to this bug.