Bug 1262712 - [New] - Cannot upgrade rhsc from 3.0.4 to 3.1.1
[New] - Cannot upgrade rhsc from 3.0.4 to 3.1.1
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
3.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 3.1.1
Assigned To: Sahina Bose
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 03:39 EDT by RamaKasturi
Modified: 2016-03-01 01:11 EST (History)
8 users (show)

See Also:
Fixed In Version: rhsc-3.1.0-65
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:11:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2015-09-14 03:39:46 EDT
Description of problem:
If user has an existing installation of 3.0.4 , upgraded to 3.1 and if he tries to upgrade it to 3.1.1 it fails with error below.

[root@dhcp37-66 ~]# rhsc-setup 
***L:ERROR Internal error: cannot import name constants_access_plugin

Doing a fresh install of 3.1 and upgrading to 3.1.1 has no issues. Upgrade goes successfully.

Version-Release number of selected component (if applicable):
rhsc-3.1.0-0.62.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have RHSC installed on 3.0.4
2. upgrade rhsc to 3.1
3. Add the latest 3.1.1 repos
4. Run yum update rhsc-setup followed by rhsc-setup

Actual results:
rhsc-setup fails with error "***L:ERROR Internal error: cannot import name constants_access_plugin"

Expected results:
rhsc-setup should run successfully.

Additional info:
Comment 4 RamaKasturi 2015-09-16 07:02:06 EDT
Verified and works fine with build rhsc-3.1.1-0.65.el6.noarch

Performed an upgrade from RHSC 3.0.4 to 3.1 and then to 3.1.1. Upgrade went fine and was successful.

Performed an upgrade from RHSC 3.1 to 3.1.1 and it went fine and was successful.

Marking this bug verified.
Comment 6 errata-xmlrpc 2016-03-01 01:11:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0310.html

Note You need to log in before you can comment on or make changes to this bug.