Bug 1262743 - user systemd-journal-upload should be in systemd-journal group
user systemd-journal-upload should be in systemd-journal group
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 04:56 EDT by Yu Watanabe
Modified: 2015-09-23 00:08 EDT (History)
7 users (show)

See Also:
Fixed In Version: 222-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 00:08:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for systemd.spec (rawhide) (1.09 KB, patch)
2015-09-14 05:01 EDT, Yu Watanabe
no flags Details | Diff

  None (edit)
Description Yu Watanabe 2015-09-14 04:56:21 EDT
Description of problem:

As specified in systemd-journal-upload.service unit file, systemd-journal-upload command is run in user systemd-journal-upload. The default journal files can be read by users who belogs to wheel, adm, or systemd-journal. So, to success systemd-journal-upload.service unit, the user systemd-journal-upload should belong one of them. I think that the group systemd-journal is proper one, in this case.

Version-Release number of selected component (if applicable):
systemd-journal-gateway-216-25.fc21.x86_64
systemd-journal-gateway-219-23.fc22.x86_64
systemd-journal-gateway-222-2.fc23.x86_64
systemd-journal-gateway-226-1.fc24.x86_64

How reproducible:
Always by stepping as follows.

Steps to Reproduce:
1. Install systemd-journal-gateway. 
2. Specify the server in journal-upload.conf
3. systemd start systemd-journal-upload.service


Actual results:

The service fail due to the daemon cannot read the journal files.

Expected results:

The service can read journal files and update it to a remote server.

Additional info:

I confirm that the service can success after I run the following command:
usermod -a -G systemd-journal systemd-journal-upload
Comment 1 Yu Watanabe 2015-09-14 05:01:45 EDT
Created attachment 1073134 [details]
patch for systemd.spec (rawhide)

I expect the patch can be also applied for f21-23.
Comment 2 Fedora Update System 2015-09-18 10:46:14 EDT
systemd-222-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16165
Comment 3 Fedora Update System 2015-09-18 20:20:37 EDT
systemd-222-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update systemd'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16165
Comment 4 Yu Watanabe 2015-09-21 19:44:54 EDT
Thaks! I will test them.
Comment 5 Yu Watanabe 2015-09-21 20:15:26 EDT
I confirm the problem is fixed. Thank you.
Comment 6 Fedora Update System 2015-09-23 00:08:09 EDT
systemd-222-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.