Bug 1262750 - DHT: mount hangs when directories are created-deleted continuously from multiple mounts
DHT: mount hangs when directories are created-deleted continuously from multi...
Status: CLOSED DUPLICATE of bug 1266834
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sakshi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 05:25 EDT by Sakshi
Modified: 2016-07-31 21:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-18 01:03:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sakshi 2015-09-14 05:25:06 EDT
Description of problem:
DHT: mount hangs when directories are created and deleted continuously from multiple mounts

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a dist-rep volume
2.Create and delete directories continuously from mount
3.Perform step 2 parallely from multiple mounts (say 4)

Actual results:
One or more mount hangs after sometime

Expected results:
Mount should not hang

Additional info:
Due to existing race between rmdir/selfheal, sometimes directories end up having gfid mismatch. Hence AFR may unlock on different gfid and not on the one it locked initially thereby blocking another client.
Comment 1 Sakshi 2016-05-18 01:03:52 EDT

*** This bug has been marked as a duplicate of bug 1286582 ***
Comment 2 Sakshi 2016-05-18 01:07:40 EDT

*** This bug has been marked as a duplicate of bug 1266834 ***

Note You need to log in before you can comment on or make changes to this bug.