Bug 1262758 - gdeploy: volume force option overrides brick_dirs value
gdeploy: volume force option overrides brick_dirs value
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity medium
: ---
: RHGS 3.1.3
Assigned To: Sachidananda Urs
Anush Shetty
: ZStream
Depends On:
Blocks: 1299184
  Show dependency treegraph
 
Reported: 2015-09-14 05:28 EDT by Anush Shetty
Modified: 2016-06-23 01:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: gdeploy-2.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:28:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-09-14 05:28:41 EDT
Description of problem: When [volume] force option is set to "yes", the [brick_dirs] values are overridden. 

Version-Release number of selected component (if applicable): gdeploy-1.0-11.el6rhs.noarch

How reproducible: Always

Steps to Reproduce:
1. Create a config file for setting up bricks:
 
gdeploy config: gluster.conf

[hosts]
rhshdp03.lab.eng.blr.redhat.com
rhshdp04.lab.eng.blr.redhat.com
rhshdp05.lab.eng.blr.redhat.com
rhshdp06.lab.eng.blr.redhat.com

[rhshdp03.lab.eng.blr.redhat.com]
devices=/dev/vdb
vgs=rhshdp03_vg1
pools=rhshdp03_pool1
lvs=rhshdp03_lv1
mountpoints=/rhshdp03/mount1
brick_dirs=/rhshdp03/mount1/rhshdp_brick1

[rhshdp04.lab.eng.blr.redhat.com]
devices=/dev/vdc
vgs=rhshdp04_vg1
pools=rhshdp04_pool1
lvs=rhshdp04_lv1
mountpoints=/rhshdp04/mount1
brick_dirs=/rhshdp03/mount1/brick1

[rhshdp05.lab.eng.blr.redhat.com]
devices=/dev/vdb
vgs=rhshdp05_vg1
pools=rhshdp05_pool1
lvs=rhshdp05_lv1
mountpoints=/rhshdp05/mount1
brick_dirs=/rhshdp03/mount1/rhshdp_brick1

[rhshdp06.lab.eng.blr.redhat.com]
devices=/dev/vdc
vgs=rhshdp06_vg1
pools=rhshdp06_pool1
lvs=rhshdp06_lv1
mountpoints=/rhshdp06/mount1
brick_dirs=/rhshdp03/mount1/brick1

[volume]
action=create
volname=gluster_vol1
replica=yes
replica_count=2
force=yes

2. Run gdeploy: gdeploy -c gluster.conf

Actual results:

The brick_dirs value isn't used while creating a volume. 

# gluster volume info
 
Volume Name: gluster_vol1
Type: Distributed-Replicate
Volume ID: ed78ac25-abb6-4cfc-8833-9b542b38e041
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: rhshdp03.lab.eng.blr.redhat.com:/rhshdp03/mount1
Brick2: rhshdp04.lab.eng.blr.redhat.com:/rhshdp04/mount1
Brick3: rhshdp05.lab.eng.blr.redhat.com:/rhshdp05/mount1
Brick4: rhshdp06.lab.eng.blr.redhat.com:/rhshdp06/mount1
Options Reconfigured:
performance.readdir-ahead: on
Comment 3 Anush Shetty 2016-04-12 03:55:42 EDT
Verified with gdeploy-2.0-5.el7rhgs.noarch
Comment 5 errata-xmlrpc 2016-06-23 01:28:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1250

Note You need to log in before you can comment on or make changes to this bug.