Bug 126278 - pcmcia not working if card is not installed at boot time ; hotplugging doesn't work
pcmcia not working if card is not installed at boot time ; hotplugging doesn'...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 07:04 EDT by Emmanuel Druon
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 11:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Druon 2004-06-18 07:04:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I'm using FC2 with lastest available upgrades on an IBM T42 (centrino)
laptop and here is the problem I have.

If a pcmcia card (a cisco 350) is not inserted before the pcmcia
service is started, there is no way to get the card recognized without
stopping the service and removing the yenta_socket module (and of
course starting all over again with modprobe yenta_socket; service
pcmcia start). Once the card is recognized, the hot(un)plugging
doesn't work either.


This bug seems quite different to others in the same category since
the card has not been pre-configured in the network part (no entry in
the /etc/modules.conf so it's not an early network start problem) and
the yenta_socket module is loaded when the pcmcia service starts.

Maybe useful information : without inserting any card, with a fresh
booted system, if I stop the pcmcia service (service pcmcia stop) I
still have two [pccardd] processes in a SW state.

I tried the same card with the same configuration on an IBM T30 (P4M
processor), the card is automatically activated and recognized, so it
seems to be a hardware issue.

Version-Release number of selected component (if applicable):
kernel 2.6.6-1.435 ; pcmcia-cs-3.2.7-1.5

How reproducible:
Always

Steps to Reproduce:
1. boot a standard system
2. Insert a pcmcia cart
3. doesn't work
    

Actual Results:  PCMCIA card is nor activated nor loaded

Expected Results:  PCMCIA card should be activated

Additional info:
Comment 1 Dax Kelson 2004-07-03 06:46:08 EDT
I'm seeing this same behavior.

I installed Debian Sarge, and observed the same problem there.

I tried the pcmcia-cs snapshot from May 2004 with the same results.

A few other data points:

I can "insert" my card after a boot, if I run "cardctl insert 1", the
leds light up and start blinking. But then if I run any commands like
"ifconfig, iwconfig" etc on the card those commands just hang.

Everything works fine and as expected under WindowsXP.
Comment 2 Dax Kelson 2004-07-03 06:48:02 EDT
My post I made the linux-thinkpad mailing list:

-----------------------------------
I have a brand new T42p. I've done a install of Fedora Core 2 that I 
updated with released errata. I've also tried kernel 2.6.7-mm5.

My problem is when I insert cardbus/pcmcia devices I get no beep, driver 
load, or card activation.  My cards:

Cisco Aironet 350 PCMCIA
Xircom RealPort Ethernet+Modem CardBus

If I insert a card and do a:

cardct insert 1

Then I *do* get a beep and driver load, but if I try to use the device 
whatever command I'm using (iwconfig/ifconfig/etc) just hangs.

Something is not right. I don't suspect hardware as when I boot to WinXP 
everything works as expected.

--------------

Another datapoint. I installed Debian Sarge on free space on hard
drive and observed the same behavior.
Comment 3 Dax Kelson 2004-07-12 17:35:59 EDT
The hanging problem seems to be specific to the Cisco 350 card, and I
reproduced it with another 350 card on another laptop.

----------

Resolution/work around found!

Reset your BIOS back to factory default settings.

I found that loading the BIOS default setting that made everything
work (minus the audible beeps). The default BIOS settings has a screen
where all IRQs are *forced* to be IRQ 11, and sure enough, cat
/proc/interrupts showed everything on 11. I had changed it to "Auto"
instead of "11" and cat /proc/interrupts showed everything spread
around. Everything seemed to work great, except PCMCIA.

Resetting my BIOS back to defaults and now PCMCIA hotplug is working.

It seems that it *should* work with interrupts not all clumped up on
IRQ 11 (and indeed, Windows does work with that config), but for now
at least, my PCMCIA slots are working.
Comment 4 Matthew Miller 2005-04-26 11:04:09 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 5 Dax Kelson 2005-04-26 11:10:54 EDT
I have the same laptop. AFAIK this was fixed awhile back with a kernel update
that properly supports the chipset.
Comment 6 Matthew Miller 2005-04-26 11:29:28 EDT
sounds good.

Note You need to log in before you can comment on or make changes to this bug.