Bug 126279 - Dragging a jpeg from mozilla to desktop results in an badly named link
Dragging a jpeg from mozilla to desktop results in an badly named link
Status: CLOSED DUPLICATE of bug 125104
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
http://www.doom3.com/getdesktop.asp?n...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 07:39 EDT by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2004-06-18 07:39:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
If one drags a jpeg from the mozilla main window and drops it on the
desktop, a non working url shortcut is created.

Version-Release number of selected component (if applicable):
nautilus-2.6.0-4

How reproducible:
Always

Steps to Reproduce:
1. Start mozilla and go to
http://www.doom3.com/getdesktop.asp?num=1&size=sm
2. Drag the image from with the skulls from the browser to your
desktop (i.e. follow the Mac instructions)

Actual Results:
An incorrectly named url shortcut called desktop_1_sm.jpg is created.
This shortcut does not work because it has the wrong extension.

Expected Results:
Either
o For a correctly named shortcut to be created
o For the dragged image to be downloaded and copied to the desktop
o For an on option saying "Set this image as wallpaper?" to pop up
(this conflicts with the previous entry though)
Comment 1 Carlos Rodrigues 2004-07-09 12:48:00 EDT
I also see this bug, with any URL, not only jpg. Currently dragging
.desktop links are broken because the file doesn't get a .desktop
extension.
Comment 2 Carlos Rodrigues 2004-07-09 14:48:11 EDT
This is a dupe for bug #125104
Comment 3 Carlos Rodrigues 2004-07-09 14:48:33 EDT
I've added a patch there.
Comment 4 Alexander Larsson 2004-08-26 09:57:31 EDT

*** This bug has been marked as a duplicate of 125104 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:04:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.