Bug 1262805 - [upgrade] After upgrade from 3.5 to 3.6, probing a new 3.6 node is moving the peer to rejected state
[upgrade] After upgrade from 3.5 to 3.6, probing a new 3.6 node is moving the...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Atin Mukherjee
glusterd
:
Depends On: 1248895 1262793
Blocks: 1277823
  Show dependency treegraph
 
Reported: 2015-09-14 08:04 EDT by Atin Mukherjee
Modified: 2016-06-16 09:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1262793
: 1277823 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:36:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-09-14 08:05:51 EDT
REVIEW: http://review.gluster.org/12171 (glusterd: call glusterd_store_volinfo in bump up op-version) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 2 Vijay Bellur 2015-10-27 06:48:35 EDT
REVIEW: http://review.gluster.org/12171 (glusterd: call glusterd_store_volinfo in bump up op-version) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 3 Vijay Bellur 2015-10-28 02:01:05 EDT
COMMIT: http://review.gluster.org/12171 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit c3ed484af54e32c1ef2300cda652604d75dc9d20
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Mon Sep 14 17:09:29 2015 +0530

    glusterd: call glusterd_store_volinfo in bump up op-version
    
    After an upgrade, op-version is expected to be updated through gluster volume
    set. If the new version introduces any feature which changes volinfo structure
    without storing the default values of these new options would result into cksum
    issues.
    
    Change-Id: I57b4667f3403839811735bf66bef29e5200a9241
    BUG: 1262805
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/12171
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-by: Gaurav Kumar Garg <ggarg@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:36:54 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.