Bug 1262831 - engine db infrastructure doesn't work properly with other schemas
engine db infrastructure doesn't work properly with other schemas
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Database.Core (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Martin Perina
Lukas Svaty
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 08:51 EDT by Martin Perina
Modified: 2016-02-10 14:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:54:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
oourfali: devel_ack+
gklein: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46130 master MERGED core: Use only public schema in engine db infra Never
oVirt gerrit 46232 ovirt-engine-3.6 MERGED core: Use only public schema in engine db infra Never

  None (edit)
Description Martin Perina 2015-09-14 08:51:49 EDT
Description of problem:

In oVirt 3.6 engine and aaa-jdbc extension providing 'internal' domain are both installed in the same database using same database user. Engine is installed by default into 'public' schema, aaa-jdbc extension providing 'internal' domain is installed into 'aaa_jdbc' schema. Unfortunately engine db infrastructure functions included in common_sp.sql doesn't work properly if 'aaa_jdbc' schema is present.

Version-Release number of selected component (if applicable):

Any 3.6 version or master

How reproducible:

100%

Steps to Reproduce:

This is reproducing steps for fn_db_add_column function:
1. Create an upgrade script which will try to add column 'password_valid_to' to engine 'users' table
2. Execute engine-setup
3. Column 'password_valid_to' is not added into engine 'users' table, because column of the same name already exists in aaa-jdbc 'users' table

Actual results:

Engine database infrastructure functions doesn't work correctly if multiple schemas are present in engine database

Expected results:

Engine database infrastructure function should use only 'public' schema

Additional info:
Comment 1 Lukas Svaty 2015-11-26 11:18:08 EST
verified in rhevm-3.6.1-0.2.el6.noarch
Comment 2 Sandro Bonazzola 2015-11-27 02:54:20 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.