Bug 126285 - proxy: don't spam during an outage/traceback
proxy: don't spam during an outage/traceback
Status: CLOSED DUPLICATE of bug 309071
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 09:57 EDT by Jack Neely
Modified: 2008-07-29 11:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-29 10:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
06/18/04 -- SSL connect error (9.08 KB, text/plain)
2004-06-18 09:58 EDT, Jack Neely
no flags Details
06/18/04 -- SSL read error (8.29 KB, text/plain)
2004-06-18 09:59 EDT, Jack Neely
no flags Details
RHN Traceback (16.13 KB, text/plain)
2004-08-16 10:00 EDT, Jack Neely
no flags Details
RHN Proxy traceback (4.59 KB, text/plain)
2004-08-23 09:33 EDT, Jack Neely
no flags Details

  None (edit)
Description Jack Neely 2004-06-18 09:57:33 EDT
Description of problem:
I got quite a few emails tonight from my RHN Proxy with a couple
different SSL errors connecting with the RHN parent.  This seems to be
a regular occurance.  The date in question is 

   Fri, 18 Jun 2004 06:33:25 -0400

I'm attaching a couple emails of the different tracebacks.
Comment 1 Jack Neely 2004-06-18 09:58:36 EDT
Created attachment 101244 [details]
06/18/04 -- SSL connect error
Comment 2 Jack Neely 2004-06-18 09:59:41 EDT
Created attachment 101245 [details]
06/18/04 -- SSL read error

This error happens quite often.
Comment 3 Todd Warner 2004-06-20 11:54:19 EDT
We had a bit of downtime when we upgraded code on the hosted side at
those times. If everything is operating smoothly again, then... all
should be well.

Not overly pretty error messaging I know.. alas...

Lemme know if it happens again please.

Moving to a NEEDINFO status for the time being.
Comment 4 Jack Neely 2004-08-16 10:00:36 EDT
Created attachment 102761 [details]
RHN Traceback

I'm assuming there was maintenance on RHN last night.  Got several hundred of
the attached email.  The feature request in this case is to have a system that
understands the difference between downtime and failure and have the Proxy
servers handle it properly.
Comment 5 Jack Neely 2004-08-23 09:33:36 EDT
Created attachment 102981 [details]
RHN Proxy traceback

I got 400 copies of the above email this morning.
Comment 6 Jack Neely 2004-08-23 09:35:11 EDT
Again, if there was a maintenance window last night 1) your users
would like to know and 2) the RHN PRoxy servers should be able to
handle the difference between maintenance and failures.
Comment 7 Todd Warner 2004-09-16 00:40:58 EDT
outage policy is in the midst of revision. I assume you are on
rhn-outage-list?

Spamming admins: Yup. Changing summary to reflect this is the driving
                 issue here.

"socket.sslerror with Proxy connecting to parent"
--> "proxy: don't spam during an outage"

I.e., we need to figure out a way to inform, but not over-inform.
Probably need to digest emails maybe for tracebacks? Dunno.

Punting to you misa; it's your bag now.
Comment 9 Red Hat Bugzilla 2007-04-11 20:07:16 EDT
User bnackash@redhat.com's account has been closed
Comment 10 Red Hat Bugzilla 2007-05-03 00:16:06 EDT
User pvetere@redhat.com's account has been closed
Comment 12 Miroslav Suchý 2008-04-30 08:57:25 EDT
I think this could we doable. We should request from hosted team some method to
indicate that is outage (like definition of sorry page).
Comment 13 Miroslav Suchý 2008-07-29 10:12:13 EDT
Duplicate of 309071
Already fixed in RHN Proxy 5.1
We do not send email if there is connection error, just write up message to log.

*** This bug has been marked as a duplicate of 309071 ***

Note You need to log in before you can comment on or make changes to this bug.