Bug 1262875 - ovirt-hosted-engine-setup still prints hints about HC on 3.6 if VDSM was already configured
ovirt-hosted-engine-setup still prints hints about HC on 3.6 if VDSM was alre...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.Gluster (Show other bugs)
1.3.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.0-beta
: 1.3.0
Assigned To: Simone Tiraboschi
Nikolai Sednev
integration
: FutureFeature, Triaged
Depends On:
Blocks: 1234915
  Show dependency treegraph
 
Reported: 2015-09-14 10:05 EDT by Simone Tiraboschi
Modified: 2015-11-27 02:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:56:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
sbonazzo: planning_ack+
sbonazzo: devel_ack+
pnovotny: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46112 ovirt-hosted-engine-setup-1.3 MERGED packaging: setup: avoiding checks on glusterfs rpms Never

  None (edit)
Description Simone Tiraboschi 2015-09-14 10:05:23 EDT
Description of problem:
If vdsm was already configured and started, ovirt-hosted-engine-setup still prints hints about HC on 3.6 while it should be not supported there.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. vdsm-tool configure --force
2. systemctl start vdsmd
3. hosted-engine --deploy

Actual results:
it prints:
[ INFO  ] Stage: Environment setup
[WARNING] Cannot locate gluster packages, Hyper Converged setup support will be disabled.
[ INFO  ] Please abort the setup and install vdsm-gluster, gluster-server >= 3.7.2 and restart vdsmd service in order to gain Hyper Converged setup support.


Expected results:
No hints abut HC

Additional info:
Comment 1 Nikolai Sednev 2015-11-25 03:26:18 EST
Works for me on these components:
# rpm -qa vdsm libvirt-client sanlock qemu-kvm-rhev mom ovirt*
ovirt-vmconsole-host-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-002-2.noarch
ovirt-engine-sdk-python-3.6.0.4-0.2.20151123.gita2f81ed.el7.centos.noarch
sanlock-3.2.4-1.el7.x86_64
ovirt-setup-lib-1.0.1-0.0.master.20151119123055.gitfa908be.el7.centos.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.3.x86_64
ovirt-hosted-engine-ha-1.3.3-0.0.master.20151118145556.20151118145552.git71b535e.el7.noarch
ovirt-vmconsole-1.0.1-0.0.master.20151105234454.git3e5d52e.el7.noarch
ovirt-release36-snapshot-002-2.noarch
libvirt-client-1.2.17-13.el7.x86_64
ovirt-hosted-engine-setup-1.3.1-0.0.master.20151118143825.gitc013638.el7.centos.noarch
ovirt-host-deploy-1.4.2-0.0.master.20151122153544.gitfc808fc.el7.noarch
vdsm-4.17.10.1-0.el7ev.noarch
mom-0.5.1-2.el7.noarch
Deployment was executed on two hosts and over NFS SD.

[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          Continuing will configure this host for serving as hypervisor and create a VM where you have to install oVirt Engine afterwards.
          Are you sure you want to continue? (Yes, No)[Yes]: yes
          Configuration files: []
          Log file: /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20151125102128-kxv2oy.log
          Version: otopi-1.4.1_master (otopi-1.4.1-0.0.master.20151119131058.gitf1f8b20.el7)
          It has been detected that this program is executed through an SSH connection without using screen.
          Continuing with the installation may lead to broken installation if the network connection fails.
          It is highly recommended to abort the installation and run it inside a screen session using command "screen".
          Do you want to continue anyway? (Yes, No)[No]: yes
[ INFO  ] Hardware supports virtualization
[ INFO  ] Bridge ovirtmgmt already created
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
Comment 2 Sandro Bonazzola 2015-11-27 02:56:48 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.