Bug 1262879 - [abrt] yumex-dnf: __init__.py:1009:_populate_transaction:UnboundLocalError: local variable 'pkg' referenced before assignment
[abrt] yumex-dnf: __init__.py:1009:_populate_transaction:UnboundLocalError: l...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:870531080d70dd71af50ba9d225...
:
: 1231735 1278672 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 10:22 EDT by Christian Stadelmann
Modified: 2016-03-17 17:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: yumex-dnf-4.1.5-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-28 15:23:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.01 KB, text/plain)
2015-09-14 10:22 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-09-14 10:22:33 EDT
Description of problem:
I selected the "firefox" and "GNOME" groups for installation and then pressed the "run transactions" button. I got notified by abrt that yumex-dnf crashed, but the application still runs (and is freezed).

Version-Release number of selected component:
yumex-dnf-4.1.3-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf
executable:     /usr/bin/yumex-dnf
kernel:         4.1.6-201.fc22.x86_64
runlevel:       N 5
type:           Python3

Truncated backtrace:
__init__.py:1009:_populate_transaction:UnboundLocalError: local variable 'pkg' referenced before assignment

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/__init__.py", line 951, in on_apply_changes
    self.process_actions()
  File "/usr/lib/python3.4/site-packages/yumex/misc.py", line 145, in newFunc
    rc = func(*args, **kwargs)
  File "/usr/lib/python3.4/site-packages/yumex/__init__.py", line 1106, in process_actions
    result = self._build_from_queue()
  File "/usr/lib/python3.4/site-packages/yumex/__init__.py", line 1036, in _build_from_queue
    self._populate_transaction()
  File "/usr/lib/python3.4/site-packages/yumex/__init__.py", line 1009, in _populate_transaction
    logger.debug('%s: %s' % (rc, pkg))
UnboundLocalError: local variable 'pkg' referenced before assignment

Local variables in innermost frame:
error_msgs: set()
errors: 0
pkgs: []
trans: []
grp_id: 'epiphany'
rc: False
self: <YumexWindow object at 0x7f3c76a174c8 (yumex+YumexWindow at 0x1b6a280)>
action: 'i'

Potential duplicate: bug 1231735
Comment 1 Christian Stadelmann 2015-09-14 10:22:36 EDT
Created attachment 1073273 [details]
File: backtrace
Comment 2 Tim Lauridsen 2015-10-06 04:51:41 EDT
traceback fixed upstream

https://github.com/timlau/yumex-dnf/commit/c24221c194bd550886fa8b1ac33aba1eeda67ba8
Comment 3 Tim Lauridsen 2015-10-06 04:51:42 EDT
traceback fixed upstream

https://github.com/timlau/yumex-dnf/commit/c24221c194bd550886fa8b1ac33aba1eeda67ba8
Comment 4 Tim Lauridsen 2015-10-06 09:26:41 EDT
*** Bug 1231735 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2015-11-18 11:47:36 EST
dnfdaemon-0.3.11-1.fc23 yumex-dnf-4.1.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-554dab6cf9
Comment 6 Fedora Update System 2015-11-19 10:26:15 EST
dnfdaemon-0.3.11-1.fc23, yumex-dnf-4.1.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update yumex-dnf dnfdaemon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-554dab6cf9
Comment 7 Fedora Update System 2015-11-19 11:54:53 EST
dnfdaemon-0.3.11-1.fc23, yumex-dnf-4.1.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update yumex-dnf dnfdaemon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-554dab6cf9
Comment 8 Fedora Update System 2015-11-20 03:04:19 EST
dnfdaemon-0.3.11-1.fc22 yumex-dnf-4.1.5-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8054ed53d3
Comment 9 Tim Lauridsen 2015-11-20 03:23:49 EST
*** Bug 1278672 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2015-11-21 12:52:54 EST
dnfdaemon-0.3.11-1.fc22, yumex-dnf-4.1.5-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update yumex-dnf dnfdaemon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8054ed53d3
Comment 11 Fedora Update System 2015-11-28 15:22:55 EST
dnfdaemon-0.3.11-1.fc23, yumex-dnf-4.1.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-03-17 17:21:46 EDT
dnfdaemon-0.3.11-1.fc22, yumex-dnf-4.1.5-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.