Bug 1262888 - rlJournalStart calls /usr/bin/beakerlib-journalling which fails with ImportError: No module named rpm
Summary: rlJournalStart calls /usr/bin/beakerlib-journalling which fails with ImportEr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: beakerlib
Version: 23
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Dalibor Pospíšil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1268985 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-14 14:44 UTC by Jan Pazdziora
Modified: 2015-12-08 08:45 UTC (History)
8 users (show)

Fixed In Version: beakerlib-1.11-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-08 08:45:05 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2015-09-14 14:44:23 UTC
Description of problem:

Using rlJournalStart in beaker test calls /usr/bin/beakerlib-journalling. That fails not being able to find rpm.

Version-Release number of selected component (if applicable):

# rpm -qf /usr/share/beakerlib/beakerlib.sh /usr/bin/beakerlib-journalling
beakerlib-1.10-3.fc23.noarch
beakerlib-1.10-3.fc23.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. On Fedora 23 in bash run . /usr/share/beakerlib/beakerlib.sh ; rlJournalStart

Actual results:

# . /usr/share/beakerlib/beakerlib.sh ; rlJournalStart
Traceback (most recent call last):
  File "/usr/bin/beakerlib-journalling", line 31, in <module>
    import rpm
ImportError: No module named rpm
rlJournalStart: Failed to initialize the journal. Bailing out...
logout

Expected results:

No error about import rpm.

Additional info:

Comment 1 Dalibor Pospíšil 2015-09-21 07:53:32 UTC
Looks like rpm-python package is no longer available in the minimal install. We should probably add this requirement explicitly to beakerlib.

As an workaround try explicitly install rpm-python prior to execution of beakerlib test, there s a possibility that if F23 it is different. Please confirm this workaround.

Comment 2 Jan Pazdziora 2015-09-21 09:45:24 UTC
(In reply to Dalibor Pospíšil from comment #1)
> 
> As an workaround try explicitly install rpm-python prior to execution of
> beakerlib test, there s a possibility that if F23 it is different. Please
> confirm this workaround.

I confirm that adding

<task name="/distribution/command" role="STANDALONE">
<params>
<param name="CMDS_TO_RUN" value="dnf install -y rpm-python"/>
</params>
</task>

to the job helped.

Comment 3 Dalibor Pospíšil 2015-09-21 10:07:17 UTC
Thanks for confirmation. I will add the requirement in next release.

Comment 4 Ales Zelinka 2015-10-06 08:17:33 UTC
*** Bug 1268985 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-11-03 12:41:09 UTC
beakerlib-1.11-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f36ff57e84

Comment 7 Fedora Update System 2015-11-03 18:20:48 UTC
beakerlib-1.11-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4c96e73472

Comment 8 Fedora Update System 2015-11-03 18:56:12 UTC
beakerlib-1.11-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ba802d1bd6

Comment 9 Fedora Update System 2015-11-03 19:52:16 UTC
beakerlib-1.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7ab9feeb42

Comment 10 Fedora Update System 2015-11-03 21:50:05 UTC
beakerlib-1.11-1.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-0e03df1475

Comment 11 Fedora Update System 2015-11-05 17:19:13 UTC
beakerlib-1.11-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8f65d5290a

Comment 12 Fedora Update System 2015-11-05 20:18:08 UTC
beakerlib-1.11-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f36ff57e84

Comment 13 Fedora Update System 2015-11-17 15:51:50 UTC
beakerlib-1.11-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2015-11-17 18:23:44 UTC
beakerlib-1.11-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Jan Pazdziora 2015-11-18 09:08:57 UTC
I confirm the workaround from comment 2 is no longer needed and Fedora 23 jobs pass.

Comment 16 Fedora Update System 2015-11-19 16:49:59 UTC
beakerlib-1.11-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2015-11-20 23:24:47 UTC
beakerlib-1.11-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2015-11-21 14:26:03 UTC
beakerlib-1.11-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2015-11-21 20:29:54 UTC
beakerlib-1.11-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.