Bug 126291 - When forwarding inline, text attachments do not get sent, other do
When forwarding inline, text attachments do not get sent, other do
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 11:26 EDT by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-31 17:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2004-06-18 11:26:15 EDT
Description of problem:

When forwarding inline, text attachments do not get sent, while other
non-text attachments do

This is clearly a bug

Version-Release number of selected component (if applicable):

stock evolution in RHEL3 with all updates

How reproducible:


Steps to Reproduce:
1.  Change forwarding preferences to "inline"
2.  have someone send you an email with a text attachment
3 [details].  foward it back to them... or even yourself

  
Actual results:

The text attachment doesn't make it

Expected results:

The text attachment should make it through just like non-text attachments
Comment 1 Joshua Jensen 2004-08-23 15:21:08 EDT
Ping ???
Comment 2 Dave Malcolm 2004-08-30 17:10:59 EDT
I've done some investigation into this, but don't have a solution yet;
here's the current status:

I believe you're running Evolution 1.4.5, and the relevant code in
that version has a special-case for handling text attachments
(specifically, in function add_attachments_handle_mime_part in the
source file composer/e-msg-composer.c).  For some reason it opts to
throw away text attachments at that stage of the process.   I plan to
dig deeper and determine whether this is a logic error or a workaround
for a deeper problem.
Comment 3 Joshua Jensen 2005-01-24 13:38:02 EST
So how is this bug going?  Any progress in the past 5 months??
Comment 5 Matthew Barnes 2006-12-31 17:11:19 EST
I was able to reproduce this problem in the latest Evolution release (2.9.4).

This upstream bug report describes a similar problem in 2.8:
http://bugzilla.gnome.org/show_bug.cgi?id=387047

Since this bug was never proposed for RHEL-3, I'm closing it here and will
continue to track the problem in the upstream bug report.

Note You need to log in before you can comment on or make changes to this bug.