Bug 126293 - Wordperfect mimetype should be application/vnd.wordperfect
Wordperfect mimetype should be application/vnd.wordperfect
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks: 114907
  Show dependency treegraph
 
Reported: 2004-06-18 11:55 EDT by Caolan McNamara
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 12:36:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2004-06-18 11:55:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040308

Description of problem:
Nautilus reckons wordperfect files are application/wordperfect
because that's what shared-mime-info tells it. Abiword is registered
as application/x-wordperfect, so nothing happens

I don't see application/wordperfect on the IANA list
(http://www.iana.org/assignments/media-types/application/), so looks
like it should be application/x-wordperfect in shared-mime-info, but
then theres a new wrinkle. In March application/vnd.wordperfect was
added to the IANA list. So now it looks like shared-mime-info should
update the wordperfect type to be vnd.wordperfect.

Version-Release number of selected component (if applicable):
shared-mime-info-0.14

How reproducible:
Always

Steps to Reproduce:
1. use nautilus to browse a dir with some wordperfect files in them,
type reported is application/wordperfect

Additional info:
Comment 1 Caolan McNamara 2004-07-22 06:43:03 EDT
caolanm->jrb: ping, is this a problematic issue after all ?
Comment 2 Jonathan Blandford 2004-07-22 12:26:34 EDT
Yeah, but we should probably move the bug upstream.
Comment 3 Jonathan Blandford 2004-07-22 12:36:25 EDT
Filed at:
https://freedesktop.org/bugzilla/show_bug.cgi?id=914

Note You need to log in before you can comment on or make changes to this bug.