Bug 126295 - ethereal goes to sleep never to return
Summary: ethereal goes to sleep never to return
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: ethereal   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-18 17:19 UTC by Tom Wood
Modified: 2015-03-05 01:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-01 15:00:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Wood 2004-06-18 17:19:22 UTC
Description of problem: ethereal-0.10.3-2.2, as did some earlier
versions, after running for a while, goes into a sleep state, does not
update the displays, and can't be coaxed out of sleep.


Version-Release number of selected component (if applicable):
ethereal-0.10.3-2.2


How reproducible: Every time


Steps to Reproduce:
1. Start ethereal from a command line.
2. Start a capture.
3. Watch display after a while lock up and never change.
4. Kill ethereal-associated windows by clicking on the X.
5. Observe that the window from which you started ethereal doesn't
return a command prompt until you press <ctrl>-c.

  
Actual results: ethereal goes to sleep (S state in ps)


Expected results: ethereal keeps capturing packets


Additional info:

Comment 1 Phil Knirsch 2004-07-01 15:00:50 UTC
I've tried it with the current version of the development tree and
couldn't reproduce the problem after half an hour and several capture
tests/runs.

Read ya, Phil

Comment 2 Paul Black 2004-11-02 08:19:00 UTC
I'm currently seeing this on FC3 (both test2 and test3). The current
version I'm running is ethereal-0.10.6-3. I've not yet ethereal work
on FC3.




Note You need to log in before you can comment on or make changes to this bug.