This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1262998 - Attempting to register --consumerid=DELETED_CONSUMER tells you to use --refresh that doesn't exist.
Attempting to register --consumerid=DELETED_CONSUMER tells you to use --refre...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
high Severity low
: pre-dev-freeze
: ---
Assigned To: vritant
John Sefler
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 16:49 EDT by Adrian Likins
Modified: 2016-05-10 16:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:37:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2015-09-14 16:49:23 EDT
Description of problem:

# Register a system.
# Delete it server side
# either keep the local certs, or copy them back

# Then attempt to register with that consumer id --consumerid

[subscription-manager (master u=)]$ sudo bin/subscription-manager register --consumerid=d157351a-97d6-4e66-8759-a9f090628df5
This system is already registered. Use --force to override

# Ok, that sounds reasonable, even if I know it will still fail.

[subscription-manager (master u=)]$ sudo bin/subscription-manager register --consumerid=d157351a-97d6-4e66-8759-a9f090628df5 --force
Error: Can not force registration while attempting to recover registration with consumerid. Please use --force without --consumerid to re-register or --refresh

# Ok, that's what I thought would happen. But... --refresh? what is --refresh

[subscription-manager (master u=)]$ sudo bin/subscription-manager register --consumerid=d157351a-97d6-4e66-8759-a9f090628df5 --force --refresh
Usage: subscription-manager register [OPTIONS]

subscription-manager: error: no such option: --refresh

# There is no --refresh. The --refresh is a lie.


Version-Release number of selected component (if applicable):
github master as of 6780c53f27312e5df4f70637e11b34d1c3354b47
Comment 2 Alex Wood 2015-09-15 15:06:11 EDT
Is --refresh meant to reference the subscription-manager refresh command?  I'm wondering if just removing the '--' from the translated strings would work (and not require any string changes from translators).
Comment 3 John Sefler 2015-09-25 13:09:56 EDT
deferring to rhel-7.3.0 due to schedule and severity

This requires a string change and we are currently past String freeze and translations for rhel7.2
Comment 4 Barnaby Court 2015-11-20 11:38:35 EST
High priority due to string update
Comment 9 Shwetha Kallesh 2016-03-31 03:15:20 EDT
Marking verified!!

[root@dhcp35-15 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.15-1
subscription management rules: 5.15.1
subscription-manager: 1.16.8-8.el6
python-rhsm: 1.16.6-1.el6


[root@dhcp35-15 ~]# subscription-manager register --consumerid=f4e003cf-a904-4873-9584-6f274066ee1b --force
Error: Can not force registration while attempting to recover registration with consumerid. Please use --force without --consumerid to re-register or use the clean command and try again without --force.
Comment 11 errata-xmlrpc 2016-05-10 16:37:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.