Bug 1263014 - [RFE] IDP specific websso
[RFE] IDP specific websso
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: beta
: 8.0 (Liberty)
Assigned To: Nathan Kinder
Rodrigo Duarte
https://blueprints.launchpad.net/keys...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 18:08 EDT by Nathan Kinder
Modified: 2016-04-26 10:30 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-keystone-8.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:08:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 203525 None None None Never
OpenStack gerrit 214766 None None None Never
OpenStack gerrit 218353 None None None Never

  None (edit)
Description Nathan Kinder 2015-09-14 18:08:08 EDT
From upstream blueprint (https://blueprints.launchpad.net/keystone/+spec/federation-idp-websso):

"Currently you have to configure websso globally for keystone. I want to be able to configure it per-IDP so that i can point horizon at those individual websso endpoints rather than have to go through an additional discovery step."

See the spec and code reviews in the blueprint link above for more details.
Comment 16 Rodrigo Duarte 2016-02-17 19:18:12 EST
Verified for openstack-keystone-8.0.1-1.el7ost (current puddle).
Comment 19 errata-xmlrpc 2016-04-07 17:08:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.