Bug 1263052 - [abrt] fish: get_gconv_fcts(): fish killed by SIGSEGV
[abrt] fish: get_gconv_fcts(): fish killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fish (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andy Lutomirski
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ef1a4301fd9d337109332ea6000...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-14 23:31 EDT by Martín Cigorraga
Modified: 2015-10-31 22:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: fish-2.2.0-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-31 22:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.21 KB, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: cgroup (190 bytes, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: core_backtrace (4.79 KB, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: dso_list (1.16 KB, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: environ (3.50 KB, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: maps (5.70 KB, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: mountinfo (3.69 KB, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: open_fds (348 bytes, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: proc_pid_status (1008 bytes, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details
File: var_log_messages (283 bytes, text/plain)
2015-09-14 23:31 EDT, Martín Cigorraga
no flags Details

  None (edit)
Description Martín Cigorraga 2015-09-14 23:31:25 EDT
Description of problem:
First time I see this happen. I got an alert message right after signing into my account from the GDM.

Version-Release number of selected component:
fish-2.2.0-3.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        -fish
crash_function: get_gconv_fcts
executable:     /usr/bin/fish
global_pid:     955
kernel:         4.1.6-201.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 get_gconv_fcts at wcsmbsload.h:71
 #1 __mbsrtowcs_l at mbsrtowcs_l.c:61
 #2 __mbsrtowcs at mbsrtowcs.c:33
 #3 _IO_vfwprintf at vfprintf.c:1642
 #4 buffered_vfprintf at vfprintf.c:2350
 #5 _IO_vfwprintf at vfprintf.c:1296
 #6 __fwprintf_chk at fwprintf_chk.c:35
 #7 fwprintf at /usr/include/bits/wchar2.h:348
 #8 show_stackframe at common.cpp:122
 #9 exec_job at exec.cpp:1177
Comment 1 Martín Cigorraga 2015-09-14 23:31:32 EDT
Created attachment 1073472 [details]
File: backtrace
Comment 2 Martín Cigorraga 2015-09-14 23:31:34 EDT
Created attachment 1073473 [details]
File: cgroup
Comment 3 Martín Cigorraga 2015-09-14 23:31:37 EDT
Created attachment 1073474 [details]
File: core_backtrace
Comment 4 Martín Cigorraga 2015-09-14 23:31:39 EDT
Created attachment 1073475 [details]
File: dso_list
Comment 5 Martín Cigorraga 2015-09-14 23:31:41 EDT
Created attachment 1073476 [details]
File: environ
Comment 6 Martín Cigorraga 2015-09-14 23:31:44 EDT
Created attachment 1073477 [details]
File: limits
Comment 7 Martín Cigorraga 2015-09-14 23:31:46 EDT
Created attachment 1073478 [details]
File: maps
Comment 8 Martín Cigorraga 2015-09-14 23:31:48 EDT
Created attachment 1073479 [details]
File: mountinfo
Comment 9 Martín Cigorraga 2015-09-14 23:31:50 EDT
Created attachment 1073480 [details]
File: namespaces
Comment 10 Martín Cigorraga 2015-09-14 23:31:52 EDT
Created attachment 1073481 [details]
File: open_fds
Comment 11 Martín Cigorraga 2015-09-14 23:31:55 EDT
Created attachment 1073482 [details]
File: proc_pid_status
Comment 12 Martín Cigorraga 2015-09-14 23:31:57 EDT
Created attachment 1073483 [details]
File: var_log_messages
Comment 13 Andy Lutomirski 2015-09-15 21:00:36 EDT
Upstream: https://github.com/fish-shell/fish-shell/issues/2392
Comment 14 Fedora Update System 2015-09-24 17:28:45 EDT
fish-2.2.0-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0aa8ea22c4
Comment 15 Fedora Update System 2015-09-24 17:30:40 EDT
fish-2.2.0-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0054dbfcf8
Comment 16 Andy Lutomirski 2015-09-24 17:57:19 EDT
Martín, any chance you could test the new build here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=687813

it'll show up in updates-testing soon, too.  I can't reproduce this problem, but I think I have a fix.
Comment 17 Martín Cigorraga 2015-09-24 21:43:45 EDT
Hello Andy, thank you very much for taking the time to look after this ticket.

I confirm that so far "fish, version 2.2.0" is working as expected. Should I stumble into any issue I will be reporting back.

Test systems:
F22 GNOME Shell edition with updates up to Sept. 24th applied from the 'updates' and 'updates-testing' repositories.
F22 Server with updates up to Sept. 24th applied from the 'updates' repository.

Note: if you're okay with this I will test this new package for a week before closing this ticket.

Cheers.
Comment 18 Andy Lutomirski 2015-09-25 11:55:20 EDT
Just to make sure: are you running from updates-testing or directly from Koji?  I don't think the (hopefully) fixed build has hit updates-testing yet.  You can find out using:

$ rpm -q fish

(Diagnosing weird bugs you can't reproduce is so much fun!)

--Andy
Comment 19 Fedora Update System 2015-09-25 12:32:09 EDT
fish-2.2.0-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update fish'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0054dbfcf8
Comment 20 Martín Cigorraga 2015-09-25 12:37:49 EDT
(Diagnosing weird bugs you can't reproduce is so much fun!) xD

Hi Andy,
I'm running the one you kindly pointed out at Koji:
~ rpm -q fish
fish-2.2.0-4.fc22.x86_64

That's said, both my systems are updated with the packages from the repos I mentioned previously.

Best!
Comment 21 Fedora Update System 2015-09-26 20:38:11 EDT
fish-2.2.0-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update fish'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0aa8ea22c4
Comment 22 Fedora Update System 2015-10-17 18:56:14 EDT
fish-2.2.0-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2015-10-31 22:48:43 EDT
fish-2.2.0-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.