Bug 1263066 - Mysql pod keeps restarting with persistent volum after changing db password
Mysql pod keeps restarting with persistent volum after changing db password
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Scott Dodson
DeShuai Ma
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 01:19 EDT by Wenjing Zheng
Modified: 2015-11-23 09:25 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 09:25:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2015-09-15 01:19:29 EDT
Description of problem:
After change password, mysql pod which attached pv keeps restarting with below errors:
[root@dhcp-128-8 db-templates]# oc logs mysql-2-h9657 -n mysql1
Starting local mysqld server ...
Waiting for MySQL to start ...
150914 23:13:04 [Warning] One can only use the --user switch if running as root

150914 23:13:04 [Note] Plugin 'FEDERATED' is disabled.
150914 23:13:04 InnoDB: The InnoDB memory heap is disabled
150914 23:13:04 InnoDB: Mutexes and rw_locks use GCC atomic builtins
150914 23:13:04 InnoDB: Compressed tables use zlib 1.2.7
150914 23:13:04 InnoDB: Using Linux native AIO
150914 23:13:04 InnoDB: Initializing buffer pool, size = 128.0M
150914 23:13:04 InnoDB: Completed initialization of buffer pool
150914 23:13:04 InnoDB: highest supported file format is Barracuda.
150914 23:13:05  InnoDB: Waiting for the background threads to start
Waiting for MySQL to start ...
150914 23:13:06 InnoDB: 5.5.41 started; log sequence number 1595675
150914 23:13:06 [Warning] 'user' entry 'root@mysql-1-54u38' ignored in --skip-name-resolve mode.
150914 23:13:06 [Warning] 'user' entry '@mysql-1-54u38' ignored in --skip-name-resolve mode.
150914 23:13:06 [Warning] 'proxies_priv' entry '@ root@mysql-1-54u38' ignored in --skip-name-resolve mode.
150914 23:13:06 [Note] Event Scheduler: Loaded 0 events
150914 23:13:06 [Note] /opt/rh/mysql55/root/usr/libexec/mysqld: ready for connections.
Version: '5.5.41'  socket: '/tmp/mysql.sock'  port: 0  MySQL Community Server (GPL)
ERROR 1133 (42000) at line 1: Can't find any matching row in the user table


Version-Release number of selected component (if applicable):
openshift3/mysql-55-rhel7    32a09cd71e61
openshift v3.0.2.0
kubernetes v1.1.0-alpha.0-1605-g44c91b1

How reproducible:
always

Steps to Reproduce:
1. Create Persistentvolume as cluster-admin with below file:
$cat pv.json
apiVersion: v1
kind: PersistentVolume
metadata:
  name: pv0001
spec:
  capacity:
    storage: 512Mi
  accessModes:
    - ReadWriteOnce
  nfs:
    path: /nfsshare
    server: <nfs_server>
$oc create -f pv.json
2. Create a new project
3. Process and create resources with persistent template file
4. Wait until pod is running, change password:
$oc env dc/mysql MYSQL_PASSWORD=redhat MYSQL_ROOT_PASSWORD=redhat
5. Check the pod status

Actual results:
The pod keeps restarting.

Expected results:
The pod should be running after password being changed.

Additional info:
Comment 5 Wenjing Zheng 2015-09-16 02:26:23 EDT
Verified with new mysql-55-rhel7 image with image id c3d990247510.

(Change Scott's comment to private since the registry is for internal usage)
Comment 6 Brenton Leanhardt 2015-11-23 09:25:57 EST
This fix is available in OpenShift Enterprise 3.1.

Note You need to log in before you can comment on or make changes to this bug.