Bug 126311 - dvips fails with certain dvi files
dvips fails with certain dvi files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-18 17:26 EDT by Carlos A. Villegas
Modified: 2013-07-02 19:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 03:17:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to pdftex.map file that fixes the issue (1.05 KB, patch)
2004-06-18 17:28 EDT, Carlos A. Villegas
no flags Details | Diff

  None (edit)
Description Carlos A. Villegas 2004-06-18 17:26:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a)
Gecko/20030728 Mozilla Firebird/0.6.1

Description of problem:

When using dvips on certain dvi files it fails with the following error:

$ dvips -o doc.ps doc.dvi 
This is dvips(k) 5.92b Copyright 2002 Radical Eye Software
(www.radicaleye.com)
' TeX output 2004.06.18:1623' -> doc.ps
dvips: ! Couldn't find header file tx8r.enc
$ 

The error ocurrs because of an incorrect mapping in font map file,
there are 4 files in total that have this "bug", 2 belong to tetex and
the other 2 to tetex-dvips:

/usr/share/texmf/pdftex/config/context/original-youngryu-tx.map
/usr/share/texmf/pdftex/config/context/original-youngryu-px.map
/usr/share/texmf/pdvips/config/pdftex.map
/usr/share/texmf/dvips/config/pdftex.map

The error is that it mentions a non existent file "tx8r.enc",
replacing every ocurrance with "8r.enc" fixes the problem.


Version-Release number of selected component (if applicable):
tetex-dvips-2.0.2-13

How reproducible:
Sometimes

Steps to Reproduce:
1.Install tetex tetex-dvi
2.Create a dvi file, this is the part I can't reproduce, some do it,
some don't, I can't create a small file, and can't send the ones I have...
3. run dvips on that file, see it fail
    

Actual Results:  
dvips fails

Expected Results:  
dvips should create a ps file from the dvi file

Additional info:


Although the problem appears in 4 files, I only had to change it in
one of them to make the problem dissappear (apparently) from dvips,
that file is:

/usr/share/texmf/dvips/config/pdftex.map

owned by the tetex-dvips rpm. I'll post the patch for that file for
clarity.
Comment 1 Carlos A. Villegas 2004-06-18 17:28:47 EDT
Created attachment 101249 [details]
patch to pdftex.map file that fixes the issue
Comment 2 Tim Waugh 2004-06-25 07:44:09 EDT
Broken since the fix for #60164 was applied I guess.  I've fixed the
spec file to use '8r' instead of 'tx8r' in the replacements for those
lines.  Thanks.
Comment 3 Jindrich Novy 2005-02-21 03:17:27 EST
It looks like Tim fixed this already for tetex-2.0.2 and it looks like it's no 
more problem with tetex-3.0. However tetex-3.0 contains many changes so if a 
similar bug occurs there please file another bugreport.

thanks,
Jindrich

Note You need to log in before you can comment on or make changes to this bug.