Bug 1263130 - Non-administrator user can't access dashboard
Non-administrator user can't access dashboard
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Dashboard (Show other bugs)
6.1.1
x86_64 Linux
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Katello Bug Bin
Corey Welton
Verified in Upstream
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 03:56 EDT by Cesar Ryan Mindana
Modified: 2016-07-27 04:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:56:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cesar Ryan Mindana 2015-09-15 03:56:16 EDT
Description of problem:
A non-administrator user can't view the Content Dashboard even if "Viewer" or "All" default roles are assigned to the particular user.

Version-Release number of selected component (if applicable):
OS: Red Hat Enterprise Linux Server release 6.7 (Santiago)
Red Hat Satellite 6.1.1

Installed Packages
    foreman-selinux-1.7.2.13-1.el6_6sat.noarch
    foreman-compute-1.7.2.33-1.el6_6sat.noarch
    foreman-postgresql-1.7.2.33-1.el6_6sat.noarch
    foreman-gce-1.7.2.33-1.el6_6sat.noarch
    foreman-debug-1.7.2.33-1.el6_6sat.noarch
    foreman-1.7.2.33-1.el6_6sat.noarch
    foreman-libvirt-1.7.2.33-1.el6_6sat.noarch
    foreman-proxy-1.7.2.5-1.el6_6sat.noarch
    foreman-ovirt-1.7.2.33-1.el6_6sat.noarch
    foreman-vmware-1.7.2.33-1.el6_6sat.noarch
    candlepin-0.9.49.3-1.el6.noarch
    candlepin-common-1.0.22-1.el6.noarch
    candlepin-scl-1-5.el6_4.noarch
    candlepin-scl-quartz-2.1.5-5.el6_4.noarch
    candlepin-scl-rhino-1.7R3-1.el6_4.noarch
    candlepin-scl-runtime-1-5.el6_4.noarch
    candlepin-selinux-0.9.49.3-1.el6.noarch
    candlepin-tomcat6-0.9.49.3-1.el6.noarch
    elasticsearch-0.90.10-7.el6.noarch
    katello-2.2.0.14-1.el6_6sat.noarch
    katello-certs-tools-2.2.1-1.el6_6sat.noarch
    katello-common-2.2.0.14-1.el6_6sat.noarch
    katello-debug-2.2.0.14-1.el6_6sat.noarch
    katello-default-ca-1.0-1.noarch
    katello-installer-2.3.17-1.el6_6sat.noarch
    katello-installer-base-2.3.17-1.el6_6sat.noarch
    katello-server-ca-1.0-1.noarch
    katello-service-2.2.0.14-1.el6_6sat.noarch
    libqpid-dispatch-0.4-7.el6.x86_64
    mod_wsgi-3.4-1.pulp.el6sat.x86_64
    phvc1-rhnsatellite.sdtvce.smartsdp-qpid-broker-1.0-1.noarch
    phvc1-rhnsatellite.sdtvce.smartsdp-qpid-client-cert-1.0-1.noarch
    phvc1-rhnsatellite.sdtvce.smartsdp-qpid-router-client-1.0-1.noarch
    phvc1-rhnsatellite.sdtvce.smartsdp-qpid-router-server-1.0-1.noarch
    pulp-docker-plugins-0.2.5-1.el6_6sat.noarch
    pulp-katello-0.5-1.el6_6sat.noarch
    pulp-nodes-common-2.6.0.15-1.el6_6sat.noarch
    pulp-nodes-parent-2.6.0.15-1.el6_6sat.noarch
    pulp-puppet-plugins-2.6.0.15-1.el6_6sat.noarch
    pulp-puppet-tools-2.6.0.15-1.el6_6sat.noarch
    pulp-rpm-plugins-2.6.0.15-1.el6_6sat.noarch
    pulp-selinux-2.6.0.15-1.el6_6sat.noarch
    pulp-server-2.6.0.15-1.el6_6sat.noarch
    python-gofer-qpid-2.6.2-2.el6_6sat.noarch
    python-isodate-0.5.0-4.pulp.el6_6sat.noarch
    python-kombu-3.0.24-10.pulp.el6_6sat.noarch
    python-pulp-bindings-2.6.0.15-1.el6_6sat.noarch
    python-pulp-common-2.6.0.15-1.el6_6sat.noarch
    python-pulp-docker-common-0.2.5-1.el6_6sat.noarch
    python-pulp-puppet-common-2.6.0.15-1.el6_6sat.noarch
    python-pulp-rpm-common-2.6.0.15-1.el6_6sat.noarch
    python-qpid-0.30-6.el6.noarch
    python-qpid-qmf-0.30-5.el6.x86_64
    qpid-cpp-client-0.30-9.el6.x86_64
    qpid-cpp-client-devel-0.30-9.el6.x86_64
    qpid-cpp-server-0.30-9.el6.x86_64
    qpid-cpp-server-linearstore-0.30-9.el6.x86_64
    qpid-dispatch-router-0.4-7.el6.x86_64
    qpid-java-client-0.30-3.el6.noarch
    qpid-java-common-0.30-3.el6.noarch
    qpid-proton-c-0.9-4.el6.x86_64
    qpid-qmf-0.30-5.el6.x86_64
    qpid-tools-0.30-4.el6.noarch
    ruby193-rubygem-katello-2.2.0.66-1.el6_6sat.noarch
    ruby193-rubygem-qpid_messaging-0.30.0-1.el6_6sat.x86_64
    rubygem-hammer_cli_katello-0.0.7.17-1.el6_6sat.noarch
    rubygem-smart_proxy_pulp-1.0.1.2-1.el6_6sat.noarch

How reproducible:
1. Create a user and assign all default roles (don't tick Administrator box)

Steps to Reproduce:
1. Login as the new user
2. Select Organization and go Monitor -> Content Dashboard

Actual results:
UI shows
"We're sorry, but something went wrong.
We've been notified about this issue and we'll take a look at it shortly."

Expected results:
Should be able to view the "Content Dashboard" section

Additional info:
Foreman Logs:
--- begin
2015-09-15 15:46:41 [I] Processing by Katello::DashboardController#index as HTML
2015-09-15 15:46:41 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.66/app/views/katello/common/_helptip_button.html.haml (0.2ms)
2015-09-15 15:46:41 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.66/app/views/katello/common/_helptip.html.haml (0.1ms)
2015-09-15 15:46:41 [I]   Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.66/app/views/katello/dashboard/index.html.haml within katello/layouts/katello (13.5ms)
2015-09-15 15:46:41 [I] Completed 500 Internal Server Error in 78ms
2015-09-15 15:46:41 [F] 
NameError (undefined local variable or method `anonymous_admin' for #<User:0x000000103cfa40>):
  lib/middleware/catch_json_parse_errors.rb:9:in `call'
--- end

NOTE: tried updating to latest packages, still encounter same issue.
Comment 1 Bryan Kearney 2015-10-16 12:58:49 EDT
The content dashboard is no longer in satellite. I am moving this to verification using the standard dashboard. Since we have also addressed https://bugzilla.redhat.com/show_bug.cgi?id=1021980 I assume this is fixed.
Comment 3 Cesar Ryan Mindana 2015-10-22 21:54:27 EDT
(In reply to Bryan Kearney from comment #1)
> The content dashboard is no longer in satellite. I am moving this to
> verification using the standard dashboard. Since we have also addressed
> https://bugzilla.redhat.com/show_bug.cgi?id=1021980 I assume this is fixed.

Hi Bryan, I've updated to release 6.1.2 and it is working, I can navigate to the page without any error using a non-admin user account. Thanks
Comment 4 Tazim Kolhar 2015-11-05 07:53:11 EST
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***
Version Tested:
# rpm -qa | grep foreman
foreman-proxy-1.11.0-0.develop.201510201341git00875b3.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-debug-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-compute-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-gce-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-vmware-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-ovirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-release-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-libvirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510201150gitab068d9.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch

steps:
1. Login as the new user
2. Select Organization and go Monitor -> Content Dashboard

Able to view the "Content Dashboard" section
Comment 8 errata-xmlrpc 2016-07-27 04:56:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.