Bug 1263161 - [RFE] built-in pre-check to see that the Capsule/Satellite has enough filesystem space [NEEDINFO]
Summary: [RFE] built-in pre-check to see that the Capsule/Satellite has enough filesys...
Keywords:
Status: CLOSED DUPLICATE of bug 1253702
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1357839 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-15 08:51 UTC by Rishi
Modified: 2021-09-09 11:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 17:27:50 UTC
Target Upstream Version:
bkearney: needinfo? (apatel)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15494 0 None None None 2016-06-22 13:04:47 UTC
Red Hat Issue Tracker SAT-4953 0 None None None 2021-09-09 11:50:37 UTC

Description Rishi 2015-09-15 08:51:04 UTC
1. Proposed title of this feature request  
      
  In built pre-check to see that the Capsule has enough filesystem space

2. Who is the customer behind the request?  
    Account: 729867
    TAM customer: Yes
    SRM customer: Yes
    Strategic: Yes
      
3. What is the nature and description of the request?  
     When synchronising the content view from Satellite server to Capsule (hammer capsule content synchronize), there is no in built pre-check to see that the Capsule has enough filesystem space. When /var/lib fills up it corrupts the pulp db and we have to re-install the Capsule. There should be a pre-check to stop the process and tell you how much diskspace is required before the process can start.
      
4. Why does the customer need this? (List the business requirements here)  
       To avoid any capsule crashing or db corruption
      
5. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
    No
      
6. Does the customer have any specific timeline dependencies and which release would they like to target ? 
    As soon as possible

7. Is the sales team involved in this request and do they have any additional input?  
      No

8. Would the customer be able to assist in testing this functionality if implemented?  
     Yes

Comment 5 Bryan Kearney 2016-06-22 14:09:04 UTC
Upstream bug component is Installer

Comment 7 Stephen Benjamin 2016-08-23 16:53:50 UTC
*** Bug 1357839 has been marked as a duplicate of this bug. ***

Comment 8 Stephen Benjamin 2016-08-23 16:54:19 UTC
Per BZ1357839, we should check space on / too.

Comment 9 hprakash 2016-11-23 08:10:10 UTC
wondering whats the latest on this?

Comment 10 Satellite Program 2017-09-15 22:14:13 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 11 Satellite Program 2017-09-15 22:14:17 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 12 Satellite Program 2017-09-19 16:14:37 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 13 Satellite Program 2017-09-19 16:14:41 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 14 Satellite Program 2017-09-21 18:14:27 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 15 Satellite Program 2017-09-21 18:14:31 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 17 Bryan Kearney 2018-07-18 17:27:50 UTC

*** This bug has been marked as a duplicate of bug 1253702 ***


Note You need to log in before you can comment on or make changes to this bug.