Bug 1263169 - Internal compile error Fortran
Internal compile error Fortran
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
22
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 05:22 EDT by Xeku
Modified: 2015-09-30 05:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 02:30:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The archive for example (95 bytes, text/plain)
2015-09-15 05:22 EDT, Xeku
no flags Details

  None (edit)
Description Xeku 2015-09-15 05:22:10 EDT
Created attachment 1073553 [details]
The archive for example

Description of problem: Try compile with gfortran an archive with .f90 extension. with command:
gfortran archive.f90 

Output:

init2.c:37: MPFR assertion failed: (64 - 0) == ((64 - 0)/8) * 8 && sizeof(mp_limb_t) == ((64 - 0)/8)
<interno>:0:0: internal compiler error: Abortado
Comment 1 Jakub Jelinek 2015-09-15 06:07:57 EDT
It compiles just fine here (F22, x86_64).  What architecture is this on?
rpm -q --qf '%{name}-%{version}-%{release}.%{arch}\n' gcc-gfortran mpfr
Comment 2 Xeku 2015-09-25 05:56:28 EDT
Hi, thank you for your reply.

With uname -a I have:

Linux localhost.localdomain 4.1.5-200.fc22.i686 #1 SMP Tue Aug 11 00:11:41 UTC 2015 i686 i686 i386 GNU/Linux

And with rpm -q --qf '%{name}-%{version}-%{release}.%{arch}\n' gcc-gfortran mpfr
I have:

gcc-gfortran-5.1.1-4.fc22.i686
mpfr-3.1.2-8.fc22.i686
Comment 3 Marek Polacek 2015-09-29 09:44:47 EDT
Does
$ rpm -V gcc-gfortran mpfr
say anything?

I couldn't reproduce the crash either (even with -m32).
Comment 4 Xeku 2015-09-29 12:17:30 EDT
Good day:

The output is:

....L....    /usr/lib/libmpfr.so.4
.......T.  d /usr/share/doc/mpfr/AUTHORS
S.5....T.  d /usr/share/doc/mpfr/BUGS
.......T.  d /usr/share/doc/mpfr/COPYING
.......T.  d /usr/share/doc/mpfr/COPYING.LESSER
S.5....T.  d /usr/share/doc/mpfr/FAQ.html
S.5....T.  d /usr/share/doc/mpfr/NEWS
S.5....T.  d /usr/share/doc/mpfr/TODO
.......T.  d /usr/share/doc/mpfr/examples/ReadMe
S.5....T.  d /usr/share/doc/mpfr/examples/divworst.c
S.5....T.  d /usr/share/doc/mpfr/examples/rndo-add.c
S.5....T.  d /usr/share/doc/mpfr/examples/sample.c
S.5....T.  d /usr/share/doc/mpfr/examples/version.c
Comment 5 Marek Polacek 2015-09-29 12:19:18 EDT
I don't think you should see an output like that.  Can you try re-installing mpfr?
Comment 6 Jakub Jelinek 2015-09-29 12:26:37 EDT
So, what does
ls -l /usr/lib/libmpfr.so.4
print?  The L above indicates that most likely it is not the /usr/lib/libmpfr.so.4.1.2 that it should point to.  Do you have some other libmpfr installed?
Comment 7 Xeku 2015-09-29 20:47:38 EDT
ls -l /usr/lib/libmpfr.so.4
output: lrwxrwxrwx. 1 root root 16 sep 15 02:49 /usr/lib/libmpfr.so.4 -> libmpfr.so.4.1.3

 ls -l /usr/lib/libmpfr.so.4.1.2
output: -rwxr-xr-x. 1 root root 397444 dic 12  2014 /usr/lib/libmpfr.so.4.1.2

ls -l /usr/lib/libmpfr.so.4.1.3
output: -rwxr-xr-x. 1 root root 436668 sep 15 02:49 /usr/lib/libmpfr.so.4.1.3


SO, I guess that I have 2 libmpfr, right? SHould I remove libmpfr.so.4.1.2?
Comment 8 Jakub Jelinek 2015-09-30 02:30:17 EDT
Well, /usr/lib/libmpfr.so.4.1.2 is what comes from the distro, the other one is that you have somehow installed manually or whatever, and is most likely broken.
Comment 9 Xeku 2015-09-30 03:48:48 EDT
When I remove /usr/lib/libmpfr.so.4.1.3 and I try compile, the output now is it:

/usr/libexec/gcc/i686-redhat-linux/5.1.1/f951: error while loading shared libraries: libmpfr.so.4: cannot open shared object file: No such file or directory


What I should install now?
Comment 10 Jakub Jelinek 2015-09-30 03:57:09 EDT
Just run ldconfig (as root).
Comment 11 Xeku 2015-09-30 05:56:36 EDT
Thank you so much, now all works fine.

Greetings.

Note You need to log in before you can comment on or make changes to this bug.